aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-06 16:27:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-06 16:27:37 +0000
commit92558d67a463bfbb351d30e28648de03b635f024 (patch)
treea5d41b991a151e72663527a96fbc6c494565d65c /target/linux/x86/Makefile
parente1dbce411cd2a3a067f387cee011cd889486a07d (diff)
downloadupstream-92558d67a463bfbb351d30e28648de03b635f024.tar.gz
upstream-92558d67a463bfbb351d30e28648de03b635f024.tar.bz2
upstream-92558d67a463bfbb351d30e28648de03b635f024.zip
strip the kernel version suffix from target directories, except for brcm-2.4 (the -2.4 will be included in the board name here). CONFIG_LINUX_<ver>_<board> becomes CONFIG_TARGET_<board>, same for profiles.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8653 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86/Makefile')
-rw-r--r--target/linux/x86/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/x86/Makefile b/target/linux/x86/Makefile
new file mode 100644
index 0000000000..705cc84ad1
--- /dev/null
+++ b/target/linux/x86/Makefile
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH=i386
+BOARD:=x86
+BOARDNAME:=x86
+FEATURES:=squashfs jffs2 ext2
+
+LINUX_VERSION:=2.6.22.4
+
+include $(INCLUDE_DIR)/kernel-build.mk
+DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
+
+# include the profiles
+-include profiles/*.mk
+
+$(eval $(call BuildKernel))
+