aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86-2.6/image
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-01-02 19:36:39 +0000
committerNicolas Thill <nico@openwrt.org>2007-01-02 19:36:39 +0000
commit6396c634c8ccec6e9f286871f23eebb1e15b1680 (patch)
treed4dcef1adb0f87d0f9ac566379450f913bfcea38 /target/linux/x86-2.6/image
parent29d4a1d2fb9756beacb77605829cfd8b7770e0c5 (diff)
downloadupstream-6396c634c8ccec6e9f286871f23eebb1e15b1680.tar.gz
upstream-6396c634c8ccec6e9f286871f23eebb1e15b1680.tar.bz2
upstream-6396c634c8ccec6e9f286871f23eebb1e15b1680.zip
fix grub segfaults on hosts where gcc is built with stack smashing protection
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5969 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86-2.6/image')
-rw-r--r--target/linux/x86-2.6/image/grub/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/target/linux/x86-2.6/image/grub/Makefile b/target/linux/x86-2.6/image/grub/Makefile
index e30443e18c..365b327622 100644
--- a/target/linux/x86-2.6/image/grub/Makefile
+++ b/target/linux/x86-2.6/image/grub/Makefile
@@ -43,6 +43,7 @@ ifeq ($(HOST_ARCH),x86_64)
--mandir=/usr/man \
--infodir=/usr/info \
$(DISABLE_NLS) \
+ --disable-auto-linux-mem-opt \
)
endef
else
@@ -62,12 +63,20 @@ else
--localstatedir=/var \
--mandir=/usr/man \
--infodir=/usr/info \
+ $(DISABLE_NLS) \
+ --disable-auto-linux-mem-opt \
)
endef
endif
+#
+# ./configure detects whether the host compiler supports
+# -fno-stack-protector but only sets STAGE2_CFLAGS accordingly
+#
define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR)
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ GRUB_CFLAGS="\$$$$(STAGE2_CFLAGS)" \
+ STAGE1_CFLAGS="\$$$$(STAGE2_CFLAGS)"
endef
define Build/InstallDev