aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86-2.6/image/grub/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-08-07 00:04:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-08-07 00:04:25 +0000
commitd10a56dc58f6c601a9abaddbe1e9cfe4db97d57b (patch)
tree9cda5ecf22a01d8a2ac22cd1a6510d51dfd5f3c3 /target/linux/x86-2.6/image/grub/Makefile
parenta46bd6cee4e494a5879393349c2a6990996c5904 (diff)
downloadupstream-d10a56dc58f6c601a9abaddbe1e9cfe4db97d57b.tar.gz
upstream-d10a56dc58f6c601a9abaddbe1e9cfe4db97d57b.tar.bz2
upstream-d10a56dc58f6c601a9abaddbe1e9cfe4db97d57b.zip
build system cleanup/restructuring as described in http://lists.openwrt.org/pipermail/openwrt-devel/2007-August/001159.html
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8362 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/x86-2.6/image/grub/Makefile')
-rw-r--r--target/linux/x86-2.6/image/grub/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/x86-2.6/image/grub/Makefile b/target/linux/x86-2.6/image/grub/Makefile
index d37803012c..dae74e9dc2 100644
--- a/target/linux/x86-2.6/image/grub/Makefile
+++ b/target/linux/x86-2.6/image/grub/Makefile
@@ -65,8 +65,9 @@ endef
define Build/InstallDev
$(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(STAGING_DIR)" \
+ DESTDIR="$(STAGING_DIR_HOST)" \
install
+ mv $(STAGING_DIR_HOST)/usr/sbin/grub $(STAGING_DIR_HOST)/bin
endef
$(eval $(call Build/DefaultTargets))