aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86-2.6/image/grub/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-08-07 00:04:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-08-07 00:04:25 +0000
commitc6bc77ea365704f3f5c79d64aed069792a4e95b1 (patch)
tree28c9265495e6ad751fcae0d27a040b222ff2a215 /target/linux/x86-2.6/image/grub/Makefile
parent9882253827b16579bbd317f6e8c0deb75b0ca0f3 (diff)
downloadupstream-c6bc77ea365704f3f5c79d64aed069792a4e95b1.tar.gz
upstream-c6bc77ea365704f3f5c79d64aed069792a4e95b1.tar.bz2
upstream-c6bc77ea365704f3f5c79d64aed069792a4e95b1.zip
build system cleanup/restructuring as described in http://lists.openwrt.org/pipermail/openwrt-devel/2007-August/001159.html
SVN-Revision: 8362
Diffstat (limited to 'target/linux/x86-2.6/image/grub/Makefile')
-rw-r--r--target/linux/x86-2.6/image/grub/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/x86-2.6/image/grub/Makefile b/target/linux/x86-2.6/image/grub/Makefile
index d37803012c..dae74e9dc2 100644
--- a/target/linux/x86-2.6/image/grub/Makefile
+++ b/target/linux/x86-2.6/image/grub/Makefile
@@ -65,8 +65,9 @@ endef
define Build/InstallDev
$(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(STAGING_DIR)" \
+ DESTDIR="$(STAGING_DIR_HOST)" \
install
+ mv $(STAGING_DIR_HOST)/usr/sbin/grub $(STAGING_DIR_HOST)/bin
endef
$(eval $(call Build/DefaultTargets))