aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/versatile/image
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-11-08 07:31:31 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-11-08 07:31:31 +0000
commit6a61d2d905837736644acef39ce2f688764e5707 (patch)
tree93d7d1ee438e612bb2146a3f608222435899ed63 /target/linux/versatile/image
parentb6e9f1dfe08740a77da7def31ca05e8ca548bed6 (diff)
downloadupstream-6a61d2d905837736644acef39ce2f688764e5707.tar.gz
upstream-6a61d2d905837736644acef39ce2f688764e5707.tar.bz2
upstream-6a61d2d905837736644acef39ce2f688764e5707.zip
add target to be used with qemu
SVN-Revision: 23920
Diffstat (limited to 'target/linux/versatile/image')
-rw-r--r--target/linux/versatile/image/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/versatile/image/Makefile b/target/linux/versatile/image/Makefile
new file mode 100644
index 0000000000..dd0d9ee76d
--- /dev/null
+++ b/target/linux/versatile/image/Makefile
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/BuildKernel
+ cp $(LINUX_DIR)/arch/$(ARCH)/boot/$(subst ",,$(KERNELNAME)) $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
+define Image/Build
+ $(call Image/Build/$(1))
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
+endef
+
+$(eval $(call BuildImage))