aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/uml/patches-2.6.37/002-gcc4_unfortify_source.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2011-02-12 19:04:16 +0000
committerFlorian Fainelli <florian@openwrt.org>2011-02-12 19:04:16 +0000
commitb8b0e43cd559f0065aa8615c98b8d9904d24ac95 (patch)
tree038d8ebcc56c07258410f430b777a32ea0f1f9c0 /target/linux/uml/patches-2.6.37/002-gcc4_unfortify_source.patch
parent8b16eba876b8f9b794e5c6dd574d613a8b2db71a (diff)
downloadupstream-b8b0e43cd559f0065aa8615c98b8d9904d24ac95.tar.gz
upstream-b8b0e43cd559f0065aa8615c98b8d9904d24ac95.tar.bz2
upstream-b8b0e43cd559f0065aa8615c98b8d9904d24ac95.zip
add 2.6.37 support
SVN-Revision: 25484
Diffstat (limited to 'target/linux/uml/patches-2.6.37/002-gcc4_unfortify_source.patch')
-rw-r--r--target/linux/uml/patches-2.6.37/002-gcc4_unfortify_source.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/uml/patches-2.6.37/002-gcc4_unfortify_source.patch b/target/linux/uml/patches-2.6.37/002-gcc4_unfortify_source.patch
new file mode 100644
index 0000000000..2be33d02a3
--- /dev/null
+++ b/target/linux/uml/patches-2.6.37/002-gcc4_unfortify_source.patch
@@ -0,0 +1,21 @@
+--- a/arch/um/Makefile-i386
++++ b/arch/um/Makefile-i386
+@@ -39,4 +39,8 @@ KBUILD_CFLAGS += $(shell if [ $(call cc-
+ echo $(call cc-option,-fno-unit-at-a-time); \
+ else echo $(call cc-option,-funit-at-a-time); fi ;)
+
++# disable compile-time buffer checks, enabled by default on Ubuntu 8.10
++# and later
++KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
++
+ KBUILD_CFLAGS += $(cflags-y)
+--- a/arch/um/Makefile-x86_64
++++ b/arch/um/Makefile-x86_64
+@@ -24,3 +24,7 @@ LINK-y += -m64
+
+ # Do unit-at-a-time unconditionally on x86_64, following the host
+ KBUILD_CFLAGS += $(call cc-option,-funit-at-a-time)
++
++# disable compile-time buffer checks, enabled by default on Ubuntu 8.10
++# and later
++KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)