aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/uml/patches-2.6.37/001-gcc4_unit_at_a_time_i386_fix.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2011-02-12 19:04:16 +0000
committerFlorian Fainelli <florian@openwrt.org>2011-02-12 19:04:16 +0000
commitb8b0e43cd559f0065aa8615c98b8d9904d24ac95 (patch)
tree038d8ebcc56c07258410f430b777a32ea0f1f9c0 /target/linux/uml/patches-2.6.37/001-gcc4_unit_at_a_time_i386_fix.patch
parent8b16eba876b8f9b794e5c6dd574d613a8b2db71a (diff)
downloadupstream-b8b0e43cd559f0065aa8615c98b8d9904d24ac95.tar.gz
upstream-b8b0e43cd559f0065aa8615c98b8d9904d24ac95.tar.bz2
upstream-b8b0e43cd559f0065aa8615c98b8d9904d24ac95.zip
add 2.6.37 support
SVN-Revision: 25484
Diffstat (limited to 'target/linux/uml/patches-2.6.37/001-gcc4_unit_at_a_time_i386_fix.patch')
-rw-r--r--target/linux/uml/patches-2.6.37/001-gcc4_unit_at_a_time_i386_fix.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/uml/patches-2.6.37/001-gcc4_unit_at_a_time_i386_fix.patch b/target/linux/uml/patches-2.6.37/001-gcc4_unit_at_a_time_i386_fix.patch
new file mode 100644
index 0000000000..442c0ec76e
--- /dev/null
+++ b/target/linux/uml/patches-2.6.37/001-gcc4_unit_at_a_time_i386_fix.patch
@@ -0,0 +1,11 @@
+--- a/arch/um/Makefile-i386
++++ b/arch/um/Makefile-i386
+@@ -35,7 +35,7 @@ cflags-y += -ffreestanding
+ # Disable unit-at-a-time mode on pre-gcc-4.0 compilers, it makes gcc use
+ # a lot more stack due to the lack of sharing of stacklots. Also, gcc
+ # 4.3.0 needs -funit-at-a-time for extern inline functions.
+-KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0400 ] ; then \
++KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0403 ] ; then \
+ echo $(call cc-option,-fno-unit-at-a-time); \
+ else echo $(call cc-option,-funit-at-a-time); fi ;)
+