aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/uml/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-11-22 17:53:36 +0100
committerFelix Fietkau <nbd@nbd.name>2016-11-24 12:53:18 +0100
commit426e4d93bb2a36022f505d7dddeb7571dcd0b524 (patch)
treea8e8928a445775384f5cfe17cca1526b49057f1c /target/linux/uml/image/Makefile
parent4081333084a4e52a125f678e905dbbcccb9e4bd0 (diff)
downloadupstream-426e4d93bb2a36022f505d7dddeb7571dcd0b524.tar.gz
upstream-426e4d93bb2a36022f505d7dddeb7571dcd0b524.tar.bz2
upstream-426e4d93bb2a36022f505d7dddeb7571dcd0b524.zip
uml: clean up the kernel config and add squashfs+ext4/f2fs support
Replaces plain ext4 images Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/uml/image/Makefile')
-rw-r--r--target/linux/uml/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/uml/image/Makefile b/target/linux/uml/image/Makefile
index 5e7247ecdd..8e83bfeecc 100644
--- a/target/linux/uml/image/Makefile
+++ b/target/linux/uml/image/Makefile
@@ -11,7 +11,12 @@ define Image/Prepare
cp $(LINUX_DIR)/linux $(KDIR)/vmlinux.elf
endef
+define Image/Build/squashfs
+ dd if=/dev/zero of=$(KDIR)/root.squashfs bs=1024k count=0 seek=$(CONFIG_TARGET_ROOTFS_PARTSIZE)
+endef
+
define Image/Build
+ $(call Image/Build/$(1))
cp $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).img
cp $(KDIR)/vmlinux.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux
endef