aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/uml-2.6/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-13 20:51:49 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-13 20:51:49 +0000
commit5b2f37e0cd7ef98a06611fb42b947d8984f0e12a (patch)
treed993cf48b4d89166701fe2f33976389d7634235d /target/linux/uml-2.6/Makefile
parent79c3b44dbfbd6fb819a0daf64c2b797c29b04d85 (diff)
parent4b8e77121f1bcca81025c3fcb7b87bf869bef7f9 (diff)
downloadupstream-5b2f37e0cd7ef98a06611fb42b947d8984f0e12a.tar.gz
upstream-5b2f37e0cd7ef98a06611fb42b947d8984f0e12a.tar.bz2
upstream-5b2f37e0cd7ef98a06611fb42b947d8984f0e12a.zip
finally move buildroot-ng to trunk
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5059 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/uml-2.6/Makefile')
-rw-r--r--target/linux/uml-2.6/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/uml-2.6/Makefile b/target/linux/uml-2.6/Makefile
new file mode 100644
index 0000000000..59f02b3340
--- /dev/null
+++ b/target/linux/uml-2.6/Makefile
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+LINUX_VERSION:=2.6.17
+LINUX_RELEASE:=1
+LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
+
+include ./config
+include $(INCLUDE_DIR)/kernel.mk
+include $(INCLUDE_DIR)/kernel-build.mk
+
+$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
+ [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches
+ [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
+ @$(CP) config $(LINUX_DIR)/.config
+ touch $@