aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ubicom32/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-08-21 22:32:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-08-21 22:32:31 +0000
commit75ee3370d9bedff6be7a12431ceef5606252e90a (patch)
tree0922f89b75edebfce606130ea949a977e60e424b /target/linux/ubicom32/Makefile
parent5076142aa3d85e3d8a0da1531ae61ecc8e90cf99 (diff)
downloadupstream-75ee3370d9bedff6be7a12431ceef5606252e90a.tar.gz
upstream-75ee3370d9bedff6be7a12431ceef5606252e90a.tar.bz2
upstream-75ee3370d9bedff6be7a12431ceef5606252e90a.zip
add a new target for ubicom32 (compiles, but untested)
SVN-Revision: 17350
Diffstat (limited to 'target/linux/ubicom32/Makefile')
-rw-r--r--target/linux/ubicom32/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/ubicom32/Makefile b/target/linux/ubicom32/Makefile
new file mode 100644
index 0000000000..7bdbd204e8
--- /dev/null
+++ b/target/linux/ubicom32/Makefile
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2006-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+#Add target specific (nommu) flags
+TARGET_CFLAGS+= -DNO_FORK
+
+ARCH:=ubicom32
+BOARD:=ubicom32
+BOARDNAME:=Ubicom IPxx
+FEATURES:=nommu
+
+LINUX_VERSION:=2.6.28.10
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNEL_MAKEOPTS += LDFLAGS_BUILD_ID=""
+
+define Target/Description
+ Build firmware images for Ubicom based routers and media devices.
+endef
+
+$(eval $(call BuildTarget))