aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/tegra/image/Makefile
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tmn505@gmail.com>2020-11-25 17:10:04 +0100
committerPetr Štetiar <ynezz@true.cz>2020-12-22 18:59:10 +0100
commitbbd665f38d6b48e56bb5ef38ee0eeceb02a8e129 (patch)
tree5a225e9a81b733becfcf7d222799b4d9547c7e91 /target/linux/tegra/image/Makefile
parentfa7705103714a2abf8b3771712b002a6d46076c8 (diff)
downloadupstream-bbd665f38d6b48e56bb5ef38ee0eeceb02a8e129.tar.gz
upstream-bbd665f38d6b48e56bb5ef38ee0eeceb02a8e129.tar.bz2
upstream-bbd665f38d6b48e56bb5ef38ee0eeceb02a8e129.zip
tegra: image: make bootscript standalone
Don't hard-code the PTUUID, use U-Boot commands to determine it, as some partitioning tools could rewrite PTUUID when modifying partitions. Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
Diffstat (limited to 'target/linux/tegra/image/Makefile')
-rw-r--r--target/linux/tegra/image/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/target/linux/tegra/image/Makefile b/target/linux/tegra/image/Makefile
index aa0083f9ae..fbff1cf6e8 100644
--- a/target/linux/tegra/image/Makefile
+++ b/target/linux/tegra/image/Makefile
@@ -14,10 +14,7 @@ define Build/tegra-sdcard
$(if $(DEVICE_DTS),\
$(foreach dtb,$(DEVICE_DTS),$(CP) $(DTS_DIR)/$(dtb).dtb $@.boot), \
$(CP) $(DTS_DIR)/*.dtb $@.boot)
- sed \
- -e 's#@ROOT@#$(IMG_PART_SIGNATURE)#g' \
- -e 's#@KERNEL@#$(KERNEL_NAME)#g' \
- $(BOOT_SCRIPT) > $@-boot.scr
+ sed -e 's#@KERNEL@#$(KERNEL_NAME)#g' $(BOOT_SCRIPT) > $@-boot.scr
mkimage -A arm -O linux -T script -C none -a 0 -e 0 \
-n '$(DEVICE_TITLE) OpenWrt bootscript' \
-d $@-boot.scr \