aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/tegra/Makefile
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2019-04-01 19:25:38 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2019-04-06 14:48:46 +0200
commit42f96ed9413a3483b0448581374feeb3343f6f6a (patch)
tree64dcc9c3a418ecec29a6654d75746574e4c0902a /target/linux/tegra/Makefile
parentde3eb0d8a060b1eb4e4027ebc435bb412ce8e096 (diff)
downloadupstream-42f96ed9413a3483b0448581374feeb3343f6f6a.tar.gz
upstream-42f96ed9413a3483b0448581374feeb3343f6f6a.tar.bz2
upstream-42f96ed9413a3483b0448581374feeb3343f6f6a.zip
tegra: add new target
New target introduces initial support for NVIDIA Tegra SoC based devices. It focuses on Tegra 2 CPUs, for successors supporting NEON instruction set the target should be split in two subtargets. This initial commit doesn't create any device image, it's groundwork for further additions. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'target/linux/tegra/Makefile')
-rw-r--r--target/linux/tegra/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/tegra/Makefile b/target/linux/tegra/Makefile
new file mode 100644
index 0000000000..57cb902cfd
--- /dev/null
+++ b/target/linux/tegra/Makefile
@@ -0,0 +1,29 @@
+#
+# Copyright (C) 2017-2019 Tomasz Maciej Nowak <tomek_n@o2.pl>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH := arm
+BOARD := tegra
+BOARDNAME := NVIDIA Tegra
+FEATURES := audio boot-part display ext4 fpu gpio pci pcie rootfs-part rtc squashfs usb
+CPU_TYPE := cortex-a9
+CPU_SUBTYPE := vfpv3
+MAINTAINER := Tomasz Maciej Nowak <tomek_n@o2.pl>
+
+KERNEL_PATCHVER := 4.14
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME := zImage dtbs
+
+DEFAULT_PACKAGES += e2fsprogs mkf2fs partx-utils
+
+define Target/Description
+ Build firmware image for NVIDIA Tegra SoC devices.
+endef
+
+$(eval $(call BuildTarget))