aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi
diff options
context:
space:
mode:
authorChukun Pan <amadeus@jmu.edu.cn>2022-09-01 23:18:19 +0800
committerChristian Lamparter <chunkeey@gmail.com>2022-12-12 09:06:17 +0100
commita125d46a287061f0a5a81c9009880b957212d74e (patch)
treea126b2498fbca92a03dde9c55449d762299fa0d4 /target/linux/sunxi
parent19b3b14e54ca30848cab5bdd9bf441b25ec025de (diff)
downloadupstream-a125d46a287061f0a5a81c9009880b957212d74e.tar.gz
upstream-a125d46a287061f0a5a81c9009880b957212d74e.tar.bz2
upstream-a125d46a287061f0a5a81c9009880b957212d74e.zip
sunxi: modules: remove useless AddDepends/rtc
AddDepends/rtc has been removed in commit 3da7fe6, same here. Fixes: 3da7fe6 ("kernel: remove useless AddDepends/rtc abstraction") Signed-off-by: Chukun Pan <amadeus@jmu.edu.cn> (RTC_SUPPORT - though this is implied by the TARGET_sunxi) Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/sunxi')
-rw-r--r--target/linux/sunxi/modules.mk6
1 files changed, 2 insertions, 4 deletions
diff --git a/target/linux/sunxi/modules.mk b/target/linux/sunxi/modules.mk
index 99f4db7604..0c8ed83d0d 100644
--- a/target/linux/sunxi/modules.mk
+++ b/target/linux/sunxi/modules.mk
@@ -5,8 +5,7 @@
define KernelPackage/rtc-sunxi
SUBMENU:=$(OTHER_MENU)
TITLE:=Sunxi SoC built-in RTC support
- DEPENDS:=@TARGET_sunxi
- $(call AddDepends/rtc)
+ DEPENDS:=@(TARGET_sunxi&&RTC_SUPPORT)
KCONFIG:= \
CONFIG_RTC_DRV_SUNXI \
CONFIG_RTC_CLASS=y
@@ -23,8 +22,7 @@ $(eval $(call KernelPackage,rtc-sunxi))
define KernelPackage/sunxi-ir
SUBMENU:=$(OTHER_MENU)
TITLE:=Sunxi SoC built-in IR support (A20)
- DEPENDS:=@TARGET_sunxi +kmod-input-core
- $(call AddDepends/rtc)
+ DEPENDS:=@(TARGET_sunxi&&RTC_SUPPORT) +kmod-input-core
KCONFIG:= \
CONFIG_MEDIA_SUPPORT=y \
CONFIG_MEDIA_RC_SUPPORT=y \