aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi
diff options
context:
space:
mode:
authorZhao Yu <574249312@qq.com>2021-08-28 10:35:12 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2021-11-20 21:08:25 +0100
commite178d9a5494747a9b6ea34f2fc9e798b4b1ecc16 (patch)
tree96ef0ef3d72c2bc9040f40490cc572aed5af4304 /target/linux/sunxi
parent454ebdf1c98317790a103b4497d45b7ad2133fe0 (diff)
downloadupstream-e178d9a5494747a9b6ea34f2fc9e798b4b1ecc16.tar.gz
upstream-e178d9a5494747a9b6ea34f2fc9e798b4b1ecc16.tar.bz2
upstream-e178d9a5494747a9b6ea34f2fc9e798b4b1ecc16.zip
sunxi: add rtc-sun6i driver package
AP6212 wifi need wifi_pwrseq, but from OrangePi Lite 2 dts : wifi_pwrseq: wifi_pwrseq { compatible = "mmc-pwrseq-simple"; clocks = <&rtc 1>; clock-names = "ext_clock"; reset-gpios = <&r_pio 1 3 GPIO_ACTIVE_LOW>; /* PM3 */ post-power-on-delay-ms = <200>; }; this pwrseq need rtc clock, or kernel won't find this device. but now rtc-sunxi.c only support A10/A20. Orangepi Lite 2 use H6 ,from rtc-sun6i.c show compatible is { .compatible = "allwinner,sun6i-a31-rtc" }, { .compatible = "allwinner,sun8i-a23-rtc" }, { .compatible = "allwinner,sun8i-h3-rtc" }, { .compatible = "allwinner,sun8i-r40-rtc" }, { .compatible = "allwinner,sun8i-v3-rtc" }, { .compatible = "allwinner,sun50i-h5-rtc" }, { .compatible = "allwinner,sun50i-h6-rtc" }, So it need this to let kernel find this mmc wifi device. As suggested by hauke, let it build as package. Signed-off-by: Zhao Yu <574249312@qq.com>
Diffstat (limited to 'target/linux/sunxi')
-rw-r--r--target/linux/sunxi/modules.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/sunxi/modules.mk b/target/linux/sunxi/modules.mk
index 99f4db7604..244c9ca508 100644
--- a/target/linux/sunxi/modules.mk
+++ b/target/linux/sunxi/modules.mk
@@ -20,6 +20,24 @@ endef
$(eval $(call KernelPackage,rtc-sunxi))
+define KernelPackage/rtc-sun6i
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Sun6i SoC built-in RTC support
+ DEPENDS:=@TARGET_sunxi
+ $(call AddDepends/rtc)
+ KCONFIG:= \
+ CONFIG_RTC_DRV_SUN6I \
+ CONFIG_RTC_CLASS=y
+ FILES:=$(LINUX_DIR)/drivers/rtc/rtc-sun6i.ko
+ AUTOLOAD:=$(call AutoLoad,50,rtc-sun6i)
+endef
+
+define KernelPackage/rtc-sun6i/description
+ Support for the AllWinner sun6i SoC's onboard RTC
+endef
+
+$(eval $(call KernelPackage,rtc-sun6i))
+
define KernelPackage/sunxi-ir
SUBMENU:=$(OTHER_MENU)
TITLE:=Sunxi SoC built-in IR support (A20)