aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-03-01 08:14:37 +0000
committerJohn Crispin <blogic@openwrt.org>2016-03-01 08:14:37 +0000
commite8e35f5e43ef5a7af0bbb330f851cb4bacc08382 (patch)
treeec740a7e07499e5dee303dbfe192f3840571e91d /target/linux/sunxi
parent5f362de1246dc22828d5a660413c24d042d48d40 (diff)
downloadupstream-e8e35f5e43ef5a7af0bbb330f851cb4bacc08382.tar.gz
upstream-e8e35f5e43ef5a7af0bbb330f851cb4bacc08382.tar.bz2
upstream-e8e35f5e43ef5a7af0bbb330f851cb4bacc08382.zip
sunxi: fix uboot install location
Install uboot files to KERNEL_BUILD_DIR instead of BIN_DIR to fix ImageBuilder. Similar fixes are necessary for many (all?) other uboot targets. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> Backport of r46605 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@48835 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/sunxi')
-rw-r--r--target/linux/sunxi/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/sunxi/image/Makefile b/target/linux/sunxi/image/Makefile
index b96a360b55..19ab935f3b 100644
--- a/target/linux/sunxi/image/Makefile
+++ b/target/linux/sunxi/image/Makefile
@@ -32,7 +32,7 @@ define Image/Build/SDCard
rm -f $(KDIR)/boot.img
mkdosfs $(KDIR)/boot.img -C $(FAT32_BLOCKS)
- mcopy -i $(KDIR)/boot.img $(BIN_DIR)/uboot-sunxi-$(PROFILE)/$(IMG_PREFIX)-$(PROFILE)-boot.scr ::boot.scr
+ mcopy -i $(KDIR)/boot.img $(KDIR)/uboot-sunxi-$(PROFILE)-boot.scr ::boot.scr
mcopy -i $(KDIR)/boot.img $(DTS_DIR)/$(2).dtb ::dtb
mcopy -i $(KDIR)/boot.img $(BIN_DIR)/$(IMG_PREFIX)-uImage ::uImage
@@ -42,7 +42,7 @@ define Image/Build/SDCard
$(KDIR)/root.$(1) \
$(CONFIG_SUNXI_SD_BOOT_PARTSIZE) \
$(CONFIG_TARGET_ROOTFS_PARTSIZE) \
- $(BIN_DIR)/uboot-sunxi-$(PROFILE)/$(IMG_PREFIX)-$(PROFILE)-u-boot-with-spl.bin
+ $(KDIR)/uboot-sunxi-$(PROFILE)-u-boot-with-spl.bin
endef
define Image/Build/Profile/A10-OLinuXino-Lime