aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/profiles/00-default.mk
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2017-01-04 22:19:27 +0800
committerFelix Fietkau <nbd@nbd.name>2017-01-05 11:09:14 +0100
commit4eb0fd8283940db6a92bbba47b12a236f6adee62 (patch)
tree5e4b7613f46b6d931b225a4b9d13739e23f3ecb0 /target/linux/sunxi/profiles/00-default.mk
parent6268d496a4fea91a475dbbea24281622293d122a (diff)
downloadupstream-4eb0fd8283940db6a92bbba47b12a236f6adee62.tar.gz
upstream-4eb0fd8283940db6a92bbba47b12a236f6adee62.tar.bz2
upstream-4eb0fd8283940db6a92bbba47b12a236f6adee62.zip
sunxi: convert to new image generation method
The new Device/xxx were transformed automatically from old profiles. Most device names are now taken from basename of the corresponding kernel device tree file. Device/sun5i-a13-olimex-som is an exception because it is not explicitly supported in the kernel yet and shares the same dts file with Device/sun5i-a13-olinuxino Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'target/linux/sunxi/profiles/00-default.mk')
-rw-r--r--target/linux/sunxi/profiles/00-default.mk28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/sunxi/profiles/00-default.mk b/target/linux/sunxi/profiles/00-default.mk
new file mode 100644
index 0000000000..b7ecfb0831
--- /dev/null
+++ b/target/linux/sunxi/profiles/00-default.mk
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2017 Yousong Zhou
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile (all drivers)
+ PACKAGES:= \
+ kmod-ata-core \
+ kmod-ata-sunxi \
+ kmod-brcmfmac \
+ kmod-rtc-sunxi \
+ kmod-rtl8192cu \
+ kmod-rtl8xxxu \
+ kmod-sun4i-emac \
+ rtl8188eu-firmware \
+ swconfig \
+ uboot-sunxi-all \
+ wpad-mini
+ PRIORITY := 1
+endef
+
+define Profile/Default/Description
+ Default profile with package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))