aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/patches-3.13/172-usb-add-ehci-driver.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-02-13 13:27:14 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-02-13 13:27:14 +0000
commit2aeabcb857e32494bdb8385a2fb5c8c529fe35be (patch)
tree7a8f6420d307615cbedc82fbc6ad2e498a5a1ca8 /target/linux/sunxi/patches-3.13/172-usb-add-ehci-driver.patch
parent87573f9583f900bc82fe435ebbcff8dd72c88205 (diff)
downloadupstream-2aeabcb857e32494bdb8385a2fb5c8c529fe35be.tar.gz
upstream-2aeabcb857e32494bdb8385a2fb5c8c529fe35be.tar.bz2
upstream-2aeabcb857e32494bdb8385a2fb5c8c529fe35be.zip
upgrade 3.13 targets to 3.13.2, refresh patches
Signed-off-by: Imre Kaloz <kaloz@openwrt.org git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39582 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/sunxi/patches-3.13/172-usb-add-ehci-driver.patch')
-rw-r--r--target/linux/sunxi/patches-3.13/172-usb-add-ehci-driver.patch12
1 files changed, 1 insertions, 11 deletions
diff --git a/target/linux/sunxi/patches-3.13/172-usb-add-ehci-driver.patch b/target/linux/sunxi/patches-3.13/172-usb-add-ehci-driver.patch
index 724c73a3d9..8ff1fc5ce0 100644
--- a/target/linux/sunxi/patches-3.13/172-usb-add-ehci-driver.patch
+++ b/target/linux/sunxi/patches-3.13/172-usb-add-ehci-driver.patch
@@ -14,8 +14,6 @@ Conflicts:
3 files changed, 456 insertions(+)
create mode 100644 drivers/usb/host/ehci-sunxi.c
-diff --git a/drivers/usb/host/Kconfig b/drivers/usb/host/Kconfig
-index a9707da..db94dba 100644
--- a/drivers/usb/host/Kconfig
+++ b/drivers/usb/host/Kconfig
@@ -273,6 +273,15 @@ config USB_OCTEON_EHCI
@@ -34,11 +32,9 @@ index a9707da..db94dba 100644
endif # USB_EHCI_HCD
config USB_OXU210HP_HCD
-diff --git a/drivers/usb/host/Makefile b/drivers/usb/host/Makefile
-index 01e879e..d96053d 100644
--- a/drivers/usb/host/Makefile
+++ b/drivers/usb/host/Makefile
-@@ -39,6 +39,7 @@ obj-$(CONFIG_USB_EHCI_HCD_AT91) += ehci-atmel.o
+@@ -39,6 +39,7 @@ obj-$(CONFIG_USB_EHCI_HCD_AT91) += ehci-
obj-$(CONFIG_USB_EHCI_MSM) += ehci-msm.o
obj-$(CONFIG_USB_EHCI_TEGRA) += ehci-tegra.o
obj-$(CONFIG_USB_W90X900_EHCI) += ehci-w90x900.o
@@ -46,9 +42,6 @@ index 01e879e..d96053d 100644
obj-$(CONFIG_USB_OXU210HP_HCD) += oxu210hp-hcd.o
obj-$(CONFIG_USB_ISP116X_HCD) += isp116x-hcd.o
-diff --git a/drivers/usb/host/ehci-sunxi.c b/drivers/usb/host/ehci-sunxi.c
-new file mode 100644
-index 0000000..e7e15cc
--- /dev/null
+++ b/drivers/usb/host/ehci-sunxi.c
@@ -0,0 +1,446 @@
@@ -498,6 +491,3 @@ index 0000000..e7e15cc
+MODULE_ALIAS("platform:" DRV_NAME);
+MODULE_DEVICE_TABLE(of, ehci_of_match);
+MODULE_AUTHOR("Roman Byshko <rbyshko@gmail.com>");
---
-1.8.5.1
-