aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/modules.mk
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2014-01-04 12:47:51 +0000
committerZoltan HERPAI <wigyori@uid0.hu>2014-01-04 12:47:51 +0000
commit24f6cc742b40c58219db867048b1c71687243433 (patch)
tree1eb905687b7bd689fd4a5406696cdb908d78a3d1 /target/linux/sunxi/modules.mk
parentb80a6ba693fe2f89ae057be38b1fdf04e5dc829e (diff)
downloadupstream-24f6cc742b40c58219db867048b1c71687243433.tar.gz
upstream-24f6cc742b40c58219db867048b1c71687243433.tar.bz2
upstream-24f6cc742b40c58219db867048b1c71687243433.zip
sunxi: move rtc off to module
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39195 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/sunxi/modules.mk')
-rw-r--r--target/linux/sunxi/modules.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/sunxi/modules.mk b/target/linux/sunxi/modules.mk
new file mode 100644
index 0000000000..8677a69494
--- /dev/null
+++ b/target/linux/sunxi/modules.mk
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+
+define KernelPackage/rtc-sunxi
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Sunxi SoC built-in RTC support
+ DEPENDS:=@TARGET_sunxi
+ $(call AddDepends/rtc)
+ KCONFIG:= \
+ CONFIG_RTC_CLASS=y \
+ CONFIG_RTC_DRV_SUNXI=m
+ FILES:=$(LINUX_DIR)/drivers/rtc/rtc-sunxi.ko
+ AUTOLOAD:=$(call AutoLoad,50,rtc-sunxi)
+endef
+
+define KernelPackage/rtc-sunxi/description
+ Support for the AllWinner sunXi SoC's onboard RTC
+endef
+
+$(eval $(call KernelPackage,rtc-sunxi))
+