aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image
diff options
context:
space:
mode:
authorChukun Pan <amadeus@jmu.edu.cn>2021-10-18 12:20:03 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2021-10-30 21:17:20 +0200
commitfde68cb80941a60be93ece75e808b5b407d11cc8 (patch)
tree35fa7d8756f4fc68c1589aa6a515854b4c9591ce /target/linux/sunxi/image
parente43eb16efe97a597a2ebaa9f549d1daec2c8c2ab (diff)
downloadupstream-fde68cb80941a60be93ece75e808b5b407d11cc8.tar.gz
upstream-fde68cb80941a60be93ece75e808b5b407d11cc8.tar.bz2
upstream-fde68cb80941a60be93ece75e808b5b407d11cc8.zip
sunxi: add support for FriendlyARM NanoPi R1S H5
Specification: CPU: Allwinner H5, Quad-core Cortex-A53 DDR3 RAM: 512MB Network: 10/100/1000M Ethernet x 2 USB Host: Type-A x 1 MicroSD Slot x 1 MicroUSB: for power input Debug Serial Port: 3Pin pin-header LED: WAN, LAN, SYS KEY: Reset Power Supply: DC 5V/2A Installation: Write the image to SD Card with dd. Note: 1. OpenWrt currently does not support LED_FUNCTION, change back to the previous practice (Consistent with NanoPi R1). 2. Since the upstream commit https://github.com/torvalds/linux/bbc4d71 ("net: phy: realtek: fix rtl8211e rx/tx delay config"), we need to change the phy-mode from rgmii to rgmii-id. So set phy-mode for 5.4 and 5.10 respectively. Signed-off-by: Chukun Pan <amadeus@jmu.edu.cn>
Diffstat (limited to 'target/linux/sunxi/image')
-rw-r--r--target/linux/sunxi/image/cortexa53.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/sunxi/image/cortexa53.mk b/target/linux/sunxi/image/cortexa53.mk
index 2d18b0b227..c88aee2d7c 100644
--- a/target/linux/sunxi/image/cortexa53.mk
+++ b/target/linux/sunxi/image/cortexa53.mk
@@ -40,6 +40,15 @@ define Device/friendlyarm_nanopi-neo2
endef
TARGET_DEVICES += friendlyarm_nanopi-neo2
+define Device/friendlyarm_nanopi-r1s-h5
+ DEVICE_VENDOR := FriendlyARM
+ DEVICE_MODEL := Nanopi R1S H5
+ DEVICE_PACKAGES := kmod-gpio-button-hotplug kmod-usb-net-rtl8152
+ SUPPORTED_DEVICES:=nanopi-r1s-h5
+ $(Device/sun50i-h5)
+endef
+TARGET_DEVICES += friendlyarm_nanopi-r1s-h5
+
define Device/libretech_all-h3-cc-h5
DEVICE_VENDOR := Libre Computer
DEVICE_MODEL := ALL-H3-CC