aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image/cortexa7.mk
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-09-10 23:02:15 +0100
committerDaniel Golle <daniel@makrotopia.org>2021-09-15 19:11:29 +0100
commit47b531de3250de24158024a39beda21328f50701 (patch)
tree5e41a997a380fbe43415d2b32a5901ee6ebd6965 /target/linux/sunxi/image/cortexa7.mk
parent23e4d90b617e2369a272e1873321c531a9296e4c (diff)
downloadupstream-47b531de3250de24158024a39beda21328f50701.tar.gz
upstream-47b531de3250de24158024a39beda21328f50701.tar.bz2
upstream-47b531de3250de24158024a39beda21328f50701.zip
sunxi: bring up DSA b53 switch on Lamobo R1
Build cortexa7 subtarget with DSA driver for MDIO-connected Broadcom BCM53xxx switches. This is needed for the Lamobo R1 aka. BananaPi BPi-R1 board which comes with such a switch IC. Remove old swconfig driver from target kernel config as the only board using it is now supported by the DSA driver. No changes to device tree are needed as upstream DTS already got a DSA switch definition and we are just using that upstream source. Update default network config of the Lamobo R1 to create lan bridge with all 4 lan ports. Introduce DEVICE_COMPAT_VERSION for the board to inform users about having the re-create their network configuration and add device alias as Bananapi BPi-R1 while at it. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/sunxi/image/cortexa7.mk')
-rw-r--r--target/linux/sunxi/image/cortexa7.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/sunxi/image/cortexa7.mk b/target/linux/sunxi/image/cortexa7.mk
index 59f11bc83c..28fac13064 100644
--- a/target/linux/sunxi/image/cortexa7.mk
+++ b/target/linux/sunxi/image/cortexa7.mk
@@ -64,7 +64,11 @@ TARGET_DEVICES += friendlyarm_zeropi
define Device/lamobo_lamobo-r1
DEVICE_VENDOR := Lamobo
DEVICE_MODEL := Lamobo R1
- DEVICE_PACKAGES:=kmod-ata-sunxi kmod-rtl8192cu swconfig wpad-basic-wolfssl
+ DEVICE_ALT0_VENDOR := Bananapi
+ DEVICE_ALT0_MODEL := BPi-R1
+ DEVICE_PACKAGES := kmod-ata-sunxi kmod-rtl8192cu wpad-basic-wolfssl
+ DEVICE_COMPAT_VERSION := 1.1
+ DEVICE_COMPAT_MESSAGE := Config cannot be migrated from swconfig to DSA
SOC := sun7i-a20
endef
TARGET_DEVICES += lamobo_lamobo-r1