aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image/cortex-a8.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-23 14:21:19 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-23 14:21:19 +0100
commitd0d8584b4187da38b484da3290fbb23ca472abad (patch)
treea5b35296fda943018d08784606552ed3825ce3fc /target/linux/sunxi/image/cortex-a8.mk
parenta8723c48add5cc8381d88234b9cdda2bb6a866aa (diff)
downloadupstream-d0d8584b4187da38b484da3290fbb23ca472abad.tar.gz
upstream-d0d8584b4187da38b484da3290fbb23ca472abad.tar.bz2
upstream-d0d8584b4187da38b484da3290fbb23ca472abad.zip
sunxi: tidy up and sort alphabetically in image Makefiles
This tidies up the image Makefiles for the sunxi target by: - Move the if-condition for the subtarget to the parent Makefile - Remove lots of unnecessary empty lines - Sort device definitions alphabetically - Harmonize line wrapping for DEVICE_PACKAGES Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/sunxi/image/cortex-a8.mk')
-rw-r--r--target/linux/sunxi/image/cortex-a8.mk63
1 files changed, 25 insertions, 38 deletions
diff --git a/target/linux/sunxi/image/cortex-a8.mk b/target/linux/sunxi/image/cortex-a8.mk
index fdebfa716c..de10d5d6cc 100644
--- a/target/linux/sunxi/image/cortex-a8.mk
+++ b/target/linux/sunxi/image/cortex-a8.mk
@@ -5,7 +5,31 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
-ifeq ($(SUBTARGET),cortexa8)
+
+define Device/cubietech_a10-cubieboard
+ DEVICE_VENDOR := Cubietech
+ DEVICE_MODEL := Cubieboard
+ DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
+ SOC := sun4i
+endef
+TARGET_DEVICES += cubietech_a10-cubieboard
+
+define Device/linksprite_a10-pcduino
+ DEVICE_VENDOR := LinkSprite
+ DEVICE_MODEL := pcDuino
+ DEVICE_PACKAGES:=kmod-sun4i-emac kmod-rtc-sunxi kmod-rtl8192cu
+ SOC := sun4i
+endef
+TARGET_DEVICES += linksprite_a10-pcduino
+
+define Device/marsboard_a10-marsboard
+ DEVICE_VENDOR := HAOYU Electronics
+ DEVICE_MODEL := MarsBoard A10
+ DEVICE_PACKAGES:=mod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi \
+ sound-soc-sunxi
+ SOC := sun4i
+endef
+TARGET_DEVICES += marsboard_a10-marsboard
define Device/olimex_a10-olinuxino-lime
DEVICE_VENDOR := Olimex
@@ -13,10 +37,8 @@ define Device/olimex_a10-olinuxino-lime
DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
SOC := sun4i
endef
-
TARGET_DEVICES += olimex_a10-olinuxino-lime
-
define Device/olimex_a13-olimex-som
DEVICE_VENDOR := Olimex
DEVICE_MODEL := A13-SOM
@@ -25,47 +47,12 @@ define Device/olimex_a13-olimex-som
SOC := sun5i-a13
SUNXI_DTS := sun5i-a13-olinuxino
endef
-
TARGET_DEVICES += olimex_a13-olimex-som
-
define Device/olimex_a13-olinuxino
DEVICE_VENDOR := Olimex
DEVICE_MODEL := A13-OLinuXino
DEVICE_PACKAGES:=kmod-rtl8192cu
SOC := sun5i
endef
-
TARGET_DEVICES += olimex_a13-olinuxino
-
-
-define Device/cubietech_a10-cubieboard
- DEVICE_VENDOR := Cubietech
- DEVICE_MODEL := Cubieboard
- DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
- SOC := sun4i
-endef
-
-TARGET_DEVICES += cubietech_a10-cubieboard
-
-
-define Device/linksprite_a10-pcduino
- DEVICE_VENDOR := LinkSprite
- DEVICE_MODEL := pcDuino
- DEVICE_PACKAGES:=kmod-sun4i-emac kmod-rtc-sunxi kmod-rtl8192cu
- SOC := sun4i
-endef
-
-TARGET_DEVICES += linksprite_a10-pcduino
-
-
-define Device/marsboard_a10-marsboard
- DEVICE_VENDOR := HAOYU Electronics
- DEVICE_MODEL := MarsBoard A10
- DEVICE_PACKAGES:=mod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi sound-soc-sunxi
- SOC := sun4i
-endef
-
-TARGET_DEVICES += marsboard_a10-marsboard
-
-endif