aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image/cortex-a8.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-06 00:11:56 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-13 12:19:44 +0100
commita4cdb537b17ede9785ddbaef5ed9d69f3ab89052 (patch)
tree370cc5b2eda165713da31bffa2a2e2b040e463ff /target/linux/sunxi/image/cortex-a8.mk
parentc642a97aa6b51352a718449cd715b92f94af4a5d (diff)
downloadupstream-a4cdb537b17ede9785ddbaef5ed9d69f3ab89052.tar.gz
upstream-a4cdb537b17ede9785ddbaef5ed9d69f3ab89052.tar.bz2
upstream-a4cdb537b17ede9785ddbaef5ed9d69f3ab89052.zip
sunxi: use vendor_device scheme for device definitions
This changes device definition to resemble the vendor_device scheme already present for the majority of device compatible strings. By doing this, we achieve several advantages at once: - Image names and node names are more consistent with other targets. - SUPPORTED_DEVICES can be set automatically for all but two cases. - Image names and node names are in line with DEVICE_TITLEs. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/sunxi/image/cortex-a8.mk')
-rw-r--r--target/linux/sunxi/image/cortex-a8.mk29
1 files changed, 12 insertions, 17 deletions
diff --git a/target/linux/sunxi/image/cortex-a8.mk b/target/linux/sunxi/image/cortex-a8.mk
index 4eeaab99d1..073ed8f2d1 100644
--- a/target/linux/sunxi/image/cortex-a8.mk
+++ b/target/linux/sunxi/image/cortex-a8.mk
@@ -7,18 +7,17 @@
#
ifeq ($(SUBTARGET),cortexa8)
-define Device/sun4i-a10-olinuxino-lime
+define Device/olimex_a10-olinuxino-lime
DEVICE_VENDOR := Olimex
DEVICE_MODEL := A10-OLinuXino-LIME
DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
- SUPPORTED_DEVICES:=olimex,a10-olinuxino-lime
SUNXI_DTS:=sun4i-a10-olinuxino-lime
endef
-TARGET_DEVICES += sun4i-a10-olinuxino-lime
+TARGET_DEVICES += olimex_a10-olinuxino-lime
-define Device/sun5i-a13-olimex-som
+define Device/olimex_a13-olimex-som
DEVICE_VENDOR := Olimex
DEVICE_MODEL := A13-SOM
DEVICE_PACKAGES:=kmod-rtl8192cu
@@ -26,50 +25,46 @@ define Device/sun5i-a13-olimex-som
SUNXI_DTS:=sun5i-a13-olinuxino
endef
-TARGET_DEVICES += sun5i-a13-olimex-som
+TARGET_DEVICES += olimex_a13-olimex-som
-define Device/sun5i-a13-olinuxino
+define Device/olimex_a13-olinuxino
DEVICE_VENDOR := Olimex
DEVICE_MODEL := A13-OLinuXino
DEVICE_PACKAGES:=kmod-rtl8192cu
- SUPPORTED_DEVICES:=olimex,a13-olinuxino
SUNXI_DTS:=sun5i-a13-olinuxino
endef
-TARGET_DEVICES += sun5i-a13-olinuxino
+TARGET_DEVICES += olimex_a13-olinuxino
-define Device/sun4i-a10-cubieboard
+define Device/cubietech_a10-cubieboard
DEVICE_VENDOR := Cubietech
DEVICE_MODEL := Cubieboard
DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
- SUPPORTED_DEVICES:=cubietech,a10-cubieboard
SUNXI_DTS:=sun4i-a10-cubieboard
endef
-TARGET_DEVICES += sun4i-a10-cubieboard
+TARGET_DEVICES += cubietech_a10-cubieboard
-define Device/sun4i-a10-pcduino
+define Device/linksprite_a10-pcduino
DEVICE_VENDOR := LinkSprite
DEVICE_MODEL := pcDuino
DEVICE_PACKAGES:=kmod-sun4i-emac kmod-rtc-sunxi kmod-rtl8192cu
- SUPPORTED_DEVICES:=linksprite,a10-pcduino
SUNXI_DTS:=sun4i-a10-pcduino
endef
-TARGET_DEVICES += sun4i-a10-pcduino
+TARGET_DEVICES += linksprite_a10-pcduino
-define Device/sun4i-a10-marsboard
+define Device/marsboard_a10-marsboard
DEVICE_VENDOR := HAOYU Electronics
DEVICE_MODEL := MarsBoard A10
DEVICE_PACKAGES:=mod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi sound-soc-sunxi
- SUPPORTED_DEVICES:=marsboard,a10-marsboard
SUNXI_DTS:=sun4i-a10-marsboard
endef
-TARGET_DEVICES += sun4i-a10-marsboard
+TARGET_DEVICES += marsboard_a10-marsboard
endif