aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image/cortex-a7.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-06 00:11:56 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-13 12:19:44 +0100
commita4cdb537b17ede9785ddbaef5ed9d69f3ab89052 (patch)
tree370cc5b2eda165713da31bffa2a2e2b040e463ff /target/linux/sunxi/image/cortex-a7.mk
parentc642a97aa6b51352a718449cd715b92f94af4a5d (diff)
downloadupstream-a4cdb537b17ede9785ddbaef5ed9d69f3ab89052.tar.gz
upstream-a4cdb537b17ede9785ddbaef5ed9d69f3ab89052.tar.bz2
upstream-a4cdb537b17ede9785ddbaef5ed9d69f3ab89052.zip
sunxi: use vendor_device scheme for device definitions
This changes device definition to resemble the vendor_device scheme already present for the majority of device compatible strings. By doing this, we achieve several advantages at once: - Image names and node names are more consistent with other targets. - SUPPORTED_DEVICES can be set automatically for all but two cases. - Image names and node names are in line with DEVICE_TITLEs. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/sunxi/image/cortex-a7.mk')
-rw-r--r--target/linux/sunxi/image/cortex-a7.mk110
1 files changed, 44 insertions, 66 deletions
diff --git a/target/linux/sunxi/image/cortex-a7.mk b/target/linux/sunxi/image/cortex-a7.mk
index 3375a4542c..32e094efb8 100644
--- a/target/linux/sunxi/image/cortex-a7.mk
+++ b/target/linux/sunxi/image/cortex-a7.mk
@@ -8,245 +8,223 @@
ifeq ($(SUBTARGET),cortexa7)
-define Device/sun7i-a20-olinuxino-lime
+define Device/olimex_a20-olinuxino-lime
DEVICE_VENDOR := Olimex
DEVICE_MODEL := A20-OLinuXino-LIME
DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-rtc-sunxi
- SUPPORTED_DEVICES:=olimex,a20-olinuxino-lime
SUNXI_DTS:=sun7i-a20-olinuxino-lime
endef
-TARGET_DEVICES += sun7i-a20-olinuxino-lime
+TARGET_DEVICES += olimex_a20-olinuxino-lime
-define Device/sun7i-a20-olinuxino-lime2
+define Device/olimex_a20-olinuxino-lime2
DEVICE_VENDOR := Olimex
DEVICE_MODEL := A20-OLinuXino-LIME2
DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-rtc-sunxi kmod-usb-hid
- SUPPORTED_DEVICES:=olimex,a20-olinuxino-lime2
SUNXI_DTS:=sun7i-a20-olinuxino-lime2
endef
-TARGET_DEVICES += sun7i-a20-olinuxino-lime2
+TARGET_DEVICES += olimex_a20-olinuxino-lime2
-define Device/sun7i-a20-olinuxino-lime2-emmc
+define Device/olimex_a20-olinuxino-lime2-emmc
DEVICE_VENDOR := Olimex
DEVICE_MODEL := A20-OLinuXino-LIME2
DEVICE_VARIANT := eMMC
DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-rtc-sunxi kmod-usb-hid
- SUPPORTED_DEVICES:=olimex,a20-olinuxino-lime2-emmc
SUNXI_DTS:=sun7i-a20-olinuxino-lime2-emmc
endef
-TARGET_DEVICES += sun7i-a20-olinuxino-lime2-emmc
+TARGET_DEVICES += olimex_a20-olinuxino-lime2-emmc
-define Device/sun7i-a20-olinuxino-micro
+define Device/olimex_a20-olinuxino-micro
DEVICE_VENDOR := Olimex
DEVICE_MODEL := A20-OLinuXino-MICRO
DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
- SUPPORTED_DEVICES:=olimex,a20-olinuxino-micro
SUNXI_DTS:=sun7i-a20-olinuxino-micro
endef
-TARGET_DEVICES += sun7i-a20-olinuxino-micro
+TARGET_DEVICES += olimex_a20-olinuxino-micro
-define Device/sun7i-a20-bananapi
+define Device/lemaker_bananapi
DEVICE_VENDOR := LeMaker
DEVICE_MODEL := Banana Pi
DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-core kmod-ata-sunxi
- SUPPORTED_DEVICES:=lemaker,bananapi
SUNXI_DTS:=sun7i-a20-bananapi
endef
-TARGET_DEVICES += sun7i-a20-bananapi
+TARGET_DEVICES += lemaker_bananapi
-define Device/sun7i-a20-bananapro
+define Device/lemaker_bananapro
DEVICE_VENDOR := LeMaker
DEVICE_MODEL := Banana Pro
DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-core kmod-ata-sunxi kmod-brcmfmac
- SUPPORTED_DEVICES:=lemaker,bananapro
SUNXI_DTS:=sun7i-a20-bananapro
endef
-TARGET_DEVICES += sun7i-a20-bananapro
+TARGET_DEVICES += lemaker_bananapro
-define Device/sun7i-a20-cubieboard2
+define Device/cubietech_cubieboard2
DEVICE_VENDOR := Cubietech
DEVICE_MODEL := Cubieboard2
DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
- SUPPORTED_DEVICES:=cubietech,cubieboard2
SUNXI_DTS:=sun7i-a20-cubieboard2
endef
-TARGET_DEVICES += sun7i-a20-cubieboard2
+TARGET_DEVICES += cubietech_cubieboard2
-define Device/sun7i-a20-cubietruck
+define Device/cubietech_cubietruck
DEVICE_VENDOR := Cubietech
DEVICE_MODEL := Cubietruck
DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-rtc-sunxi kmod-brcmfmac
- SUPPORTED_DEVICES:=cubietech,cubietruck
SUNXI_DTS:=sun7i-a20-cubietruck
endef
-TARGET_DEVICES += sun7i-a20-cubietruck
+TARGET_DEVICES += cubietech_cubietruck
-define Device/sun7i-a20-lamobo-r1
+define Device/lamobo_lamobo-r1
DEVICE_VENDOR := Lamobo
DEVICE_MODEL := Lamobo R1
DEVICE_PACKAGES:=kmod-ata-sunxi kmod-rtl8192cu swconfig wpad-basic
- SUPPORTED_DEVICES:=lamobo,lamobo-r1
SUNXI_DTS:=sun7i-a20-lamobo-r1
endef
-TARGET_DEVICES += sun7i-a20-lamobo-r1
+TARGET_DEVICES += lamobo_lamobo-r1
-define Device/sun6i-a31-m9
+define Device/mele_m9
DEVICE_VENDOR := Mele
DEVICE_MODEL := M9
DEVICE_PACKAGES:=kmod-sun4i-emac kmod-rtc-sunxi kmod-rtl8192cu
- SUPPORTED_DEVICES:=mele,m9
SUNXI_DTS:=sun6i-a31-m9
endef
-TARGET_DEVICES += sun6i-a31-m9
+TARGET_DEVICES += mele_m9
-define Device/sun8i-h2-plus-orangepi-zero
+define Device/xunlong_orangepi-zero
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi Zero
DEVICE_PACKAGES:=kmod-rtc-sunxi
- SUPPORTED_DEVICES:=xunlong,orangepi-zero
SUNXI_DTS:=sun8i-h2-plus-orangepi-zero
endef
-TARGET_DEVICES += sun8i-h2-plus-orangepi-zero
+TARGET_DEVICES += xunlong_orangepi-zero
-define Device/sun8i-h2-plus-orangepi-r1
+define Device/xunlong_orangepi-r1
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi R1
DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-usb-net kmod-usb-net-rtl8152
- SUPPORTED_DEVICES:=xunlong,orangepi-r1
SUNXI_DTS:=sun8i-h2-plus-orangepi-r1
endef
-TARGET_DEVICES += sun8i-h2-plus-orangepi-r1
+TARGET_DEVICES += xunlong_orangepi-r1
-define Device/sun8i-h3-bananapi-m2-plus
+define Device/sinovoip_bananapi-m2-plus
DEVICE_VENDOR := Sinovoip
DEVICE_MODEL := Banana Pi M2+
DEVICE_PACKAGES:=kmod-rtc-sunxi \
kmod-leds-gpio kmod-ledtrig-heartbeat \
kmod-brcmfmac brcmfmac-firmware-43430a0-sdio wpad-basic
- SUPPORTED_DEVICES:=sinovoip,bananapi-m2-plus
SUNXI_DTS:=sun8i-h3-bananapi-m2-plus
endef
-TARGET_DEVICES += sun8i-h3-bananapi-m2-plus
+TARGET_DEVICES += sinovoip_bananapi-m2-plus
-define Device/sun8i-h3-nanopi-m1-plus
+define Device/friendlyarm_nanopi-m1-plus
DEVICE_VENDOR := FriendlyARM
DEVICE_MODEL := NanoPi M1 Plus
DEVICE_PACKAGES:=kmod-rtc-sunxi \
kmod-leds-gpio kmod-ledtrig-heartbeat \
kmod-brcmfmac brcmfmac-firmware-43430-sdio wpad-basic
- SUPPORTED_DEVICES:=friendlyarm,nanopi-m1-plus
SUNXI_DTS:=sun8i-h3-nanopi-m1-plus
endef
-TARGET_DEVICES += sun8i-h3-nanopi-m1-plus
+TARGET_DEVICES += friendlyarm_nanopi-m1-plus
-define Device/sun8i-h3-nanopi-neo
+define Device/friendlyarm_nanopi-neo
DEVICE_VENDOR := FriendlyARM
DEVICE_MODEL := NanoPi NEO
- SUPPORTED_DEVICES:=friendlyarm,nanopi-neo
SUNXI_DTS:=sun8i-h3-nanopi-neo
endef
-TARGET_DEVICES += sun8i-h3-nanopi-neo
+TARGET_DEVICES += friendlyarm_nanopi-neo
-define Device/sun8i-h3-orangepi-one
+define Device/xunlong_orangepi-one
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi One
DEVICE_PACKAGES:=kmod-rtc-sunxi
- SUPPORTED_DEVICES:=xunlong,orangepi-one
SUNXI_DTS:=sun8i-h3-orangepi-one
endef
-TARGET_DEVICES += sun8i-h3-orangepi-one
+TARGET_DEVICES += xunlong_orangepi-one
-define Device/sun8i-h3-orangepi-pc
+define Device/xunlong_orangepi-pc
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi PC
DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-gpio-button-hotplug
- SUPPORTED_DEVICES:=xunlong,orangepi-pc
SUNXI_DTS:=sun8i-h3-orangepi-pc
endef
-TARGET_DEVICES += sun8i-h3-orangepi-pc
+TARGET_DEVICES += xunlong_orangepi-pc
-define Device/sun8i-h3-orangepi-pc-plus
+define Device/xunlong_orangepi-pc-plus
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi PC Plus
DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-gpio-button-hotplug
- SUPPORTED_DEVICES:=xunlong,orangepi-pc-plus
SUNXI_DTS:=sun8i-h3-orangepi-pc-plus
endef
-TARGET_DEVICES += sun8i-h3-orangepi-pc-plus
+TARGET_DEVICES += xunlong_orangepi-pc-plus
-define Device/sun8i-h3-orangepi-plus
+define Device/xunlong_orangepi-plus
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi Plus
DEVICE_PACKAGES:=kmod-rtc-sunxi
- SUPPORTED_DEVICES:=xunlong,orangepi-plus
SUNXI_DTS:=sun8i-h3-orangepi-plus
endef
-TARGET_DEVICES += sun8i-h3-orangepi-plus
+TARGET_DEVICES += xunlong_orangepi-plus
-define Device/sun8i-h3-orangepi-2
+define Device/xunlong_orangepi-2
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi 2
DEVICE_PACKAGES:=kmod-rtc-sunxi
- SUPPORTED_DEVICES:=xunlong,orangepi-2
SUNXI_DTS:=sun8i-h3-orangepi-2
endef
-TARGET_DEVICES += sun8i-h3-orangepi-2
+TARGET_DEVICES += xunlong_orangepi-2
-define Device/sun7i-a20-pcduino3
+define Device/linksprite_pcduino3
DEVICE_VENDOR := LinkSprite
DEVICE_MODEL := pcDuino3
DEVICE_PACKAGES:=kmod-sun4i-emac kmod-rtc-sunxi kmod-ata-core kmod-ata-sunxi kmod-rtl8xxxu rtl8188eu-firmware
- SUPPORTED_DEVICES:=linksprite,pcduino3
SUNXI_DTS:=sun7i-a20-pcduino3
endef
-TARGET_DEVICES += sun7i-a20-pcduino3
+TARGET_DEVICES += linksprite_pcduino3
-define Device/sun8i-r40-bananapi-m2-ultra
+define Device/lemaker_bananapi-m2-ultra
DEVICE_VENDOR := LeMaker
DEVICE_MODEL := Banana Pi M2 Ultra
DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-core kmod-ata-sunxi
- SUPPORTED_DEVICES:=lemaker,bananapi-m2-ultra
SUNXI_DTS:=sun8i-r40-bananapi-m2-ultra
endef
-TARGET_DEVICES += sun8i-r40-bananapi-m2-ultra
+TARGET_DEVICES += lemaker_bananapi-m2-ultra
endif