aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image/cortex-a7.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2017-09-26 22:41:56 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2017-10-01 17:10:33 +0200
commit5508510e744ce9dfaba23cb8639977f021bd29f9 (patch)
tree97030cac2a65c0f9c1821a9d043f16a9986f1a91 /target/linux/sunxi/image/cortex-a7.mk
parentba1aedafebcb5cb577c69d412ee3d4de262ccc32 (diff)
downloadupstream-5508510e744ce9dfaba23cb8639977f021bd29f9.tar.gz
upstream-5508510e744ce9dfaba23cb8639977f021bd29f9.tar.bz2
upstream-5508510e744ce9dfaba23cb8639977f021bd29f9.zip
sunxi: add Orange Pi R1 support
The following features are working and tested: * both Ethernet ports * MMC * LED The following features are not working: * Wifi (There is a crappy driver we could port) * SPI flash (I haven't looked into this) I haven't tried out the rest. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target/linux/sunxi/image/cortex-a7.mk')
-rw-r--r--target/linux/sunxi/image/cortex-a7.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/sunxi/image/cortex-a7.mk b/target/linux/sunxi/image/cortex-a7.mk
index ecf376fbe4..29c30ef494 100644
--- a/target/linux/sunxi/image/cortex-a7.mk
+++ b/target/linux/sunxi/image/cortex-a7.mk
@@ -108,6 +108,16 @@ endef
TARGET_DEVICES += sun6i-a31-m9
+define Device/sun8i-h2-plus-orangepi-r1
+ DEVICE_TITLE:=Xunlong Orange Pi R1
+ DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-usb-net kmod-usb-net-rtl8152
+ SUPPORTED_DEVICES:=xunlong,orangepi-r1
+ SUNXI_DTS:=sun8i-h2-plus-orangepi-r1
+endef
+
+TARGET_DEVICES += sun8i-h2-plus-orangepi-r1
+
+
define Device/sun8i-h3-orangepi-plus
DEVICE_TITLE:=Xunlong Orange Pi Plus
DEVICE_PACKAGES:=kmod-rtc-sunxi