aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image/cortex-a53.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-06 00:11:56 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-13 12:19:44 +0100
commita4cdb537b17ede9785ddbaef5ed9d69f3ab89052 (patch)
tree370cc5b2eda165713da31bffa2a2e2b040e463ff /target/linux/sunxi/image/cortex-a53.mk
parentc642a97aa6b51352a718449cd715b92f94af4a5d (diff)
downloadupstream-a4cdb537b17ede9785ddbaef5ed9d69f3ab89052.tar.gz
upstream-a4cdb537b17ede9785ddbaef5ed9d69f3ab89052.tar.bz2
upstream-a4cdb537b17ede9785ddbaef5ed9d69f3ab89052.zip
sunxi: use vendor_device scheme for device definitions
This changes device definition to resemble the vendor_device scheme already present for the majority of device compatible strings. By doing this, we achieve several advantages at once: - Image names and node names are more consistent with other targets. - SUPPORTED_DEVICES can be set automatically for all but two cases. - Image names and node names are in line with DEVICE_TITLEs. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/sunxi/image/cortex-a53.mk')
-rw-r--r--target/linux/sunxi/image/cortex-a53.mk28
1 files changed, 12 insertions, 16 deletions
diff --git a/target/linux/sunxi/image/cortex-a53.mk b/target/linux/sunxi/image/cortex-a53.mk
index 7a67160c33..d6c17d95ff 100644
--- a/target/linux/sunxi/image/cortex-a53.mk
+++ b/target/linux/sunxi/image/cortex-a53.mk
@@ -7,7 +7,7 @@
#
ifeq ($(SUBTARGET),cortexa53)
-define Device/sun50i-h5-nanopi-neo-plus2
+define Device/friendlyarm_nanopi-neo-plus2
DEVICE_VENDOR := FriendlyARM
DEVICE_MODEL := NanoPi NEO Plus2
SUPPORTED_DEVICES:=nanopi-neo-plus2
@@ -16,9 +16,9 @@ define Device/sun50i-h5-nanopi-neo-plus2
KERNEL := kernel-bin
endef
-TARGET_DEVICES += sun50i-h5-nanopi-neo-plus2
+TARGET_DEVICES += friendlyarm_nanopi-neo-plus2
-define Device/sun50i-h5-nanopi-neo2
+define Device/friendlyarm_nanopi-neo2
DEVICE_VENDOR := FriendlyARM
DEVICE_MODEL := NanoPi NEO2
SUPPORTED_DEVICES:=nanopi-neo2
@@ -27,51 +27,47 @@ define Device/sun50i-h5-nanopi-neo2
KERNEL := kernel-bin
endef
-TARGET_DEVICES += sun50i-h5-nanopi-neo2
+TARGET_DEVICES += friendlyarm_nanopi-neo2
-define Device/sun50i-a64-pine64-plus
+define Device/pine64_pine64-plus
DEVICE_VENDOR := Pine64
DEVICE_MODEL := Pine64+
- SUPPORTED_DEVICES:=pine64,pine64-plus
SUNXI_DTS:=allwinner/sun50i-a64-pine64-plus
KERNEL_NAME := Image
KERNEL := kernel-bin
endef
-TARGET_DEVICES += sun50i-a64-pine64-plus
+TARGET_DEVICES += pine64_pine64-plus
-define Device/sun50i-a64-sopine-baseboard
+define Device/pine64_sopine-baseboard
DEVICE_VENDOR := Pine64
DEVICE_MODEL := SoPine
- SUPPORTED_DEVICES:=pine64,sopine-baseboard
SUNXI_DTS:=allwinner/sun50i-a64-sopine-baseboard
KERNEL_NAME := Image
KERNEL := kernel-bin
endef
-TARGET_DEVICES += sun50i-a64-sopine-baseboard
+TARGET_DEVICES += pine64_sopine-baseboard
-define Device/sun50i-h5-orangepi-zero-plus
+define Device/xunlong_orangepi-zero-plus
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi Zero Plus
- SUPPORTED_DEVICES:=xunlong,orangepi-zero-plus
SUNXI_DTS:=allwinner/sun50i-h5-orangepi-zero-plus
KERNEL_NAME := Image
KERNEL := kernel-bin
endef
-TARGET_DEVICES += sun50i-h5-orangepi-zero-plus
+TARGET_DEVICES += xunlong_orangepi-zero-plus
-define Device/sun50i-h5-orangepi-pc2
+define Device/xunlong_orangepi-pc2
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi PC 2
- SUPPORTED_DEVICES:=xunlong,orangepi-pc2
SUNXI_DTS:=allwinner/sun50i-h5-orangepi-pc2
KERNEL_NAME := Image
KERNEL := kernel-bin
endef
-TARGET_DEVICES += sun50i-h5-orangepi-pc2
+TARGET_DEVICES += xunlong_orangepi-pc2
endif