aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image/Makefile
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-23 14:21:19 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-23 14:21:19 +0100
commitd0d8584b4187da38b484da3290fbb23ca472abad (patch)
treea5b35296fda943018d08784606552ed3825ce3fc /target/linux/sunxi/image/Makefile
parenta8723c48add5cc8381d88234b9cdda2bb6a866aa (diff)
downloadupstream-d0d8584b4187da38b484da3290fbb23ca472abad.tar.gz
upstream-d0d8584b4187da38b484da3290fbb23ca472abad.tar.bz2
upstream-d0d8584b4187da38b484da3290fbb23ca472abad.zip
sunxi: tidy up and sort alphabetically in image Makefiles
This tidies up the image Makefiles for the sunxi target by: - Move the if-condition for the subtarget to the parent Makefile - Remove lots of unnecessary empty lines - Sort device definitions alphabetically - Harmonize line wrapping for DEVICE_PACKAGES Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/sunxi/image/Makefile')
-rw-r--r--target/linux/sunxi/image/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/sunxi/image/Makefile b/target/linux/sunxi/image/Makefile
index 888c1c5a9b..705d409ac5 100644
--- a/target/linux/sunxi/image/Makefile
+++ b/target/linux/sunxi/image/Makefile
@@ -42,8 +42,16 @@ define Device/Default
SUNXI_DTS = $$(SUNXI_DTS_DIR)$$(SOC)-$(lastword $(subst _, ,$(1)))
endef
+ifeq ($(SUBTARGET),cortexa7)
include cortex-a7.mk
+endif
+
+ifeq ($(SUBTARGET),cortexa8)
include cortex-a8.mk
+endif
+
+ifeq ($(SUBTARGET),cortexa53)
include cortex-a53.mk
+endif
$(eval $(call BuildImage))