aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/image/Makefile
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-20 01:18:44 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-20 01:18:44 +0100
commitb085e0586faf4da4b2c296ddf31885dd781bd85c (patch)
tree1ea24049ae9dacb98cabe7d7653ead7f32f3d67e /target/linux/sunxi/image/Makefile
parent58e71e322bc0e0edd08157075e9022c15ae33ec5 (diff)
downloadupstream-b085e0586faf4da4b2c296ddf31885dd781bd85c.tar.gz
upstream-b085e0586faf4da4b2c296ddf31885dd781bd85c.tar.bz2
upstream-b085e0586faf4da4b2c296ddf31885dd781bd85c.zip
sunxi: rename SUNXI_SOC to SOC
This replaces SUNXI_SOC by the newly introduced common SOC device variable. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/sunxi/image/Makefile')
-rw-r--r--target/linux/sunxi/image/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/target/linux/sunxi/image/Makefile b/target/linux/sunxi/image/Makefile
index 929f4c70f9..888c1c5a9b 100644
--- a/target/linux/sunxi/image/Makefile
+++ b/target/linux/sunxi/image/Makefile
@@ -32,15 +32,14 @@ endef
# why \x00\x00\x00\x00 for zImage-initramfs
define Device/Default
PROFILES := Default
- DEVICE_VARS := SUNXI_SOC SUNXI_DTS SUNXI_DTS_DIR SUNXI_UBOOT
+ DEVICE_VARS := SUNXI_DTS SUNXI_DTS_DIR SUNXI_UBOOT
KERNEL_NAME := zImage
KERNEL := kernel-bin | uImage none
IMAGES := sdcard.img.gz
IMAGE/sdcard.img.gz := sunxi-sdcard | append-metadata | gzip
SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
- SUNXI_SOC :=
SUNXI_DTS_DIR :=
- SUNXI_DTS = $$(SUNXI_DTS_DIR)$$(SUNXI_SOC)-$(lastword $(subst _, ,$(1)))
+ SUNXI_DTS = $$(SUNXI_DTS_DIR)$$(SOC)-$(lastword $(subst _, ,$(1)))
endef
include cortex-a7.mk