aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/cortexa8
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2017-07-15 20:35:57 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2017-09-18 18:36:26 +0200
commit41e7d2e2e8796d83e82169ae5a87d022c58ab4be (patch)
treea40c689977274f76e29d269d1d315da914dc8c64 /target/linux/sunxi/cortexa8
parent4b81bb13f4005f243d14820a688150be5c350182 (diff)
downloadupstream-41e7d2e2e8796d83e82169ae5a87d022c58ab4be.tar.gz
upstream-41e7d2e2e8796d83e82169ae5a87d022c58ab4be.tar.bz2
upstream-41e7d2e2e8796d83e82169ae5a87d022c58ab4be.zip
sunxi: split into cortex A8 and A7 subtarget
Now we can activate some compiler optimizations for the cortex A7. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target/linux/sunxi/cortexa8')
-rw-r--r--target/linux/sunxi/cortexa8/config-default21
-rw-r--r--target/linux/sunxi/cortexa8/target.mk12
2 files changed, 33 insertions, 0 deletions
diff --git a/target/linux/sunxi/cortexa8/config-default b/target/linux/sunxi/cortexa8/config-default
new file mode 100644
index 0000000000..fa40deb6f8
--- /dev/null
+++ b/target/linux/sunxi/cortexa8/config-default
@@ -0,0 +1,21 @@
+# CONFIG_ARCH_PHYS_ADDR_T_64BIT is not set
+# CONFIG_ARM_ERRATA_643719 is not set
+# CONFIG_ARM_LPAE is not set
+# CONFIG_MACH_SUN6I is not set
+# CONFIG_MACH_SUN7I is not set
+# CONFIG_MACH_SUN8I is not set
+# CONFIG_MACH_SUN9I is not set
+CONFIG_PGTABLE_LEVELS=2
+# CONFIG_PHYS_ADDR_T_64BIT is not set
+# CONFIG_PINCTRL_SUN6I_A31 is not set
+# CONFIG_PINCTRL_SUN6I_A31S is not set
+# CONFIG_PINCTRL_SUN6I_A31_R is not set
+# CONFIG_PINCTRL_SUN7I_A20 is not set
+# CONFIG_PINCTRL_SUN8I_A23 is not set
+# CONFIG_PINCTRL_SUN8I_A23_R is not set
+# CONFIG_PINCTRL_SUN8I_A33 is not set
+# CONFIG_PINCTRL_SUN8I_A83T is not set
+# CONFIG_PINCTRL_SUN8I_H3 is not set
+# CONFIG_PINCTRL_SUN8I_H3_R is not set
+# CONFIG_PINCTRL_SUN9I_A80 is not set
+# CONFIG_PINCTRL_SUN9I_A80_R is not set
diff --git a/target/linux/sunxi/cortexa8/target.mk b/target/linux/sunxi/cortexa8/target.mk
new file mode 100644
index 0000000000..d7d18f6ca4
--- /dev/null
+++ b/target/linux/sunxi/cortexa8/target.mk
@@ -0,0 +1,12 @@
+#
+# Copyright (C) 2017 Hauke Mehrtens
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+BOARDNAME:=Allwinner A1x
+CPU_TYPE:=cortex-a8
+CPU_SUBTYPE:=vfpv3