aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/cortexa7
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2017-07-15 20:35:57 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2017-09-18 18:36:26 +0200
commit41e7d2e2e8796d83e82169ae5a87d022c58ab4be (patch)
treea40c689977274f76e29d269d1d315da914dc8c64 /target/linux/sunxi/cortexa7
parent4b81bb13f4005f243d14820a688150be5c350182 (diff)
downloadupstream-41e7d2e2e8796d83e82169ae5a87d022c58ab4be.tar.gz
upstream-41e7d2e2e8796d83e82169ae5a87d022c58ab4be.tar.bz2
upstream-41e7d2e2e8796d83e82169ae5a87d022c58ab4be.zip
sunxi: split into cortex A8 and A7 subtarget
Now we can activate some compiler optimizations for the cortex A7. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target/linux/sunxi/cortexa7')
-rw-r--r--target/linux/sunxi/cortexa7/config-default6
-rw-r--r--target/linux/sunxi/cortexa7/target.mk12
2 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/sunxi/cortexa7/config-default b/target/linux/sunxi/cortexa7/config-default
new file mode 100644
index 0000000000..aabfa5ab10
--- /dev/null
+++ b/target/linux/sunxi/cortexa7/config-default
@@ -0,0 +1,6 @@
+# CONFIG_MACH_SUN4I is not set
+# CONFIG_MACH_SUN5I is not set
+# CONFIG_PINCTRL_GR8 is not set
+# CONFIG_PINCTRL_SUN4I_A10 is not set
+# CONFIG_PINCTRL_SUN5I_A10S is not set
+# CONFIG_PINCTRL_SUN5I_A13 is not set
diff --git a/target/linux/sunxi/cortexa7/target.mk b/target/linux/sunxi/cortexa7/target.mk
new file mode 100644
index 0000000000..16aa9f7d0a
--- /dev/null
+++ b/target/linux/sunxi/cortexa7/target.mk
@@ -0,0 +1,12 @@
+#
+# Copyright (C) 2017 Hauke Mehrtens
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+BOARDNAME:=Allwinner A20/A3x
+CPU_TYPE:=cortex-a7
+CPU_SUBTYPE:=neon-vfpv4