aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/cortexa53/target.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2017-07-15 22:53:20 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2017-09-18 20:34:55 +0200
commit24c2f5125e253d241abed39c59f76b6417f45306 (patch)
tree9d50449b838ffeef183233860a9ebf3bdb96842a /target/linux/sunxi/cortexa53/target.mk
parent3b88f74bbe9134465a84234e1e7400af585f8c2b (diff)
downloadupstream-24c2f5125e253d241abed39c59f76b6417f45306.tar.gz
upstream-24c2f5125e253d241abed39c59f76b6417f45306.tar.bz2
upstream-24c2f5125e253d241abed39c59f76b6417f45306.zip
sunxi: Add A64 support with cortex53 subtarget
This adds initial support for the A64 Allwinner SoC to LEDE. It will be build in the new cortexa53 subtarget. Currently it only supports the pine64 and the image is able to boot on this SoC. Camera, Ethernet, HDMI and other parts are currently not working. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target/linux/sunxi/cortexa53/target.mk')
-rw-r--r--target/linux/sunxi/cortexa53/target.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/sunxi/cortexa53/target.mk b/target/linux/sunxi/cortexa53/target.mk
new file mode 100644
index 0000000000..6715d00bda
--- /dev/null
+++ b/target/linux/sunxi/cortexa53/target.mk
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2017 Hauke Mehrtens
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+ARCH:=aarch64
+BOARDNAME:=Allwinner A64
+CPU_TYPE:=cortex-a53
+KERNELNAME:=Image dtbs