aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/Makefile
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2013-11-14 23:12:52 +0000
committerZoltan HERPAI <wigyori@uid0.hu>2013-11-14 23:12:52 +0000
commit448a6b8d51f92ff19995645ff99f7f49804482fc (patch)
tree76658ab5db8672127f7cb73adb2682a83e432727 /target/linux/sunxi/Makefile
parent4e381a077c60fb9518cc754c470094436f3f9c4d (diff)
downloadupstream-448a6b8d51f92ff19995645ff99f7f49804482fc.tar.gz
upstream-448a6b8d51f92ff19995645ff99f7f49804482fc.tar.bz2
upstream-448a6b8d51f92ff19995645ff99f7f49804482fc.zip
sunxi: rework target
- update kernel to 3.12 - add patches for clocks, i2c, usb, sid, rtc - support common image for A10/A13/A20 - add support for a couple boards - most drivers are configured into the kernel as of now Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38811 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/sunxi/Makefile')
-rw-r--r--target/linux/sunxi/Makefile21
1 files changed, 14 insertions, 7 deletions
diff --git a/target/linux/sunxi/Makefile b/target/linux/sunxi/Makefile
index e60f550360..658de40028 100644
--- a/target/linux/sunxi/Makefile
+++ b/target/linux/sunxi/Makefile
@@ -4,19 +4,26 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
+
include $(TOPDIR)/rules.mk
ARCH:=arm
BOARD:=sunxi
-BOARDNAME:=Allwinner SoC
-FEATURES:=targz
-SUBTARGETS=cortex-a7 cortex-a8
-MAINTAINER:=Luka Perkov <luka@openwrt.org>
+BOARDNAME:=Allwinner A1x/A20/A3x
+FEATURES:=fpu usb ext4 display
+CPU_TYPE:=cortex-a8
+CPU_SUBTYPE:=vfpv3
+MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
-LINUX_VERSION:=3.10.18
+LINUX_VERSION:=3.12
+KERNELNAME:="zImage dtbs"
+DEFAULT_PACKAGES += uboot-envtools uboot-sunxi
-include $(INCLUDE_DIR)/target.mk
+# A10: Cortex-A8
+# A13: Cortex-A8
+# A20: dual Cortex-A7
+# A31: quad Cortex-A7
-KERNELNAME:="zImage dtbs"
+include $(INCLUDE_DIR)/target.mk
$(eval $(call BuildTarget))