aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/storm/patches/1100-gpio.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-06-05 17:10:39 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-06-05 17:10:39 +0000
commitcc7c0a18fb758e25783c147a51094412a16c687e (patch)
tree36496e13270435c09e3f8c1880929d94bd26733a /target/linux/storm/patches/1100-gpio.patch
parent6ffc241131436ea399f2afe5d144c4f5eed79f49 (diff)
downloadupstream-cc7c0a18fb758e25783c147a51094412a16c687e.tar.gz
upstream-cc7c0a18fb758e25783c147a51094412a16c687e.tar.bz2
upstream-cc7c0a18fb758e25783c147a51094412a16c687e.zip
* refresh storm patches
* disable BX in uClibc config, add ethernet and watchdog support -- thanks to Zilvinas Valinskas git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11367 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/storm/patches/1100-gpio.patch')
-rw-r--r--target/linux/storm/patches/1100-gpio.patch20
1 files changed, 7 insertions, 13 deletions
diff --git a/target/linux/storm/patches/1100-gpio.patch b/target/linux/storm/patches/1100-gpio.patch
index 34e9c52bdd..de9c4da375 100644
--- a/target/linux/storm/patches/1100-gpio.patch
+++ b/target/linux/storm/patches/1100-gpio.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.23.17/drivers/char/gemini_gpio_dev.c
-===================================================================
--- /dev/null
-+++ linux-2.6.23.17/drivers/char/gemini_gpio_dev.c
++++ b/drivers/char/gemini_gpio_dev.c
@@ -0,0 +1,356 @@
+/*
+ * GPIO driver for Gemini board
@@ -359,11 +357,9 @@ Index: linux-2.6.23.17/drivers/char/gemini_gpio_dev.c
+MODULE_AUTHOR("Jonas Majauskas");
+MODULE_LICENSE("GPL");
+
-Index: linux-2.6.23.17/drivers/char/Kconfig
-===================================================================
---- linux-2.6.23.17.orig/drivers/char/Kconfig
-+++ linux-2.6.23.17/drivers/char/Kconfig
-@@ -1064,5 +1064,12 @@ config DEVPORT
+--- a/drivers/char/Kconfig
++++ b/drivers/char/Kconfig
+@@ -1064,5 +1064,12 @@
source "drivers/s390/char/Kconfig"
@@ -376,11 +372,9 @@ Index: linux-2.6.23.17/drivers/char/Kconfig
+
endmenu
-Index: linux-2.6.23.17/drivers/char/Makefile
-===================================================================
---- linux-2.6.23.17.orig/drivers/char/Makefile
-+++ linux-2.6.23.17/drivers/char/Makefile
-@@ -115,6 +115,7 @@ obj-$(CONFIG_IPMI_HANDLER) += ipmi/
+--- a/drivers/char/Makefile
++++ b/drivers/char/Makefile
+@@ -115,6 +115,7 @@
obj-$(CONFIG_HANGCHECK_TIMER) += hangcheck-timer.o
obj-$(CONFIG_TCG_TPM) += tpm/