aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/storm/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-04-27 17:03:01 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-04-27 17:03:01 +0000
commit3166c564d96709eea69fd48b89587d78577b49f7 (patch)
tree44a709d369ce31f92fa83676b58e430e25233d01 /target/linux/storm/Makefile
parentac347b46b0f895afc1b473a2ed5574d82863f2da (diff)
downloadupstream-3166c564d96709eea69fd48b89587d78577b49f7.tar.gz
upstream-3166c564d96709eea69fd48b89587d78577b49f7.tar.bz2
upstream-3166c564d96709eea69fd48b89587d78577b49f7.zip
add preliminary support for Storm SL3512 based devices, not ready yet
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10956 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/storm/Makefile')
-rw-r--r--target/linux/storm/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/storm/Makefile b/target/linux/storm/Makefile
new file mode 100644
index 0000000000..c0d0023cc1
--- /dev/null
+++ b/target/linux/storm/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2006-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=storm
+BOARDNAME:=Storm SL3512
+FEATURES:=squashfs pci broken
+
+LINUX_VERSION:=2.6.23.16
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build images for boards based on the Storm Semiconductor SL3512, eg. Wiligear WBD-111
+endef
+
+define Kernel/Configure
+ $(call Kernel/Configure/Default)
+ $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
+ $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
+endef
+
+$(eval $(call BuildTarget))