aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/samsung
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-28 16:08:38 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-03 00:04:22 +0100
commit1b44ecc2d71606bf9faf45361deef398849e2c4f (patch)
treea63912e3c4930a10f6ca703c7e61baa8db6a794a /target/linux/samsung
parent6e70e4a071b233da83486414e65d15756ede63d2 (diff)
downloadupstream-1b44ecc2d71606bf9faf45361deef398849e2c4f.tar.gz
upstream-1b44ecc2d71606bf9faf45361deef398849e2c4f.tar.bz2
upstream-1b44ecc2d71606bf9faf45361deef398849e2c4f.zip
samsung: add subtarget condition for device
The only device in samsung target is meant to be built with s5pv210 subtarget. Thus, though this won't make a difference for a one-subtarget target, already add the condition to the Makefile to make the assignment obvious. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/samsung')
-rw-r--r--target/linux/samsung/image/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/samsung/image/Makefile b/target/linux/samsung/image/Makefile
index 53509ef137..3648562704 100644
--- a/target/linux/samsung/image/Makefile
+++ b/target/linux/samsung/image/Makefile
@@ -17,6 +17,8 @@ define Device/Default
DEVICE_DTS = $$(SOC)_$(1)
endef
+ifeq ($(SUBTARGET),s5pv210)
+
define Device/embedsky_tq210
DEVICE_VENDOR := EmbedSky
DEVICE_MODEL := TQ210
@@ -24,4 +26,6 @@ define Device/embedsky_tq210
endef
TARGET_DEVICES += embedsky_tq210
+endif
+
$(eval $(call BuildImage))