aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/samsung/image/Makefile
diff options
context:
space:
mode:
authorJianhui Zhao <jianhuizhao329@gmail.com>2018-04-17 11:09:14 +0800
committerJohn Crispin <john@phrozen.org>2018-07-30 14:10:00 +0200
commit84c212da44cf5df210ae166ed7e64adf764ccf3f (patch)
tree2351260a551bca0f71fbf482671a7da70d5842f0 /target/linux/samsung/image/Makefile
parent4caab808300ad75575d778bae6e184caa26aeabc (diff)
downloadupstream-84c212da44cf5df210ae166ed7e64adf764ccf3f.tar.gz
upstream-84c212da44cf5df210ae166ed7e64adf764ccf3f.tar.bz2
upstream-84c212da44cf5df210ae166ed7e64adf764ccf3f.zip
samsung/s5pv210: New target
Signed-off-by: Jianhui Zhao <jianhuizhao329@gmail.com>
Diffstat (limited to 'target/linux/samsung/image/Makefile')
-rw-r--r--target/linux/samsung/image/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/samsung/image/Makefile b/target/linux/samsung/image/Makefile
new file mode 100644
index 0000000000..f0b1842caa
--- /dev/null
+++ b/target/linux/samsung/image/Makefile
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2018 Jianhui Zhao <jianhuizhao329@gmail.com>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+KERNEL_LOADADDR := 0x20008000
+
+define Device/Default
+ PROFILES = Default
+ KERNEL_NAME := zImage
+ KERNEL := kernel-bin | append-dtb | uImage none
+endef
+
+define Device/tq210
+ DEVICE_DTS_DIR := ../dts
+ DEVICE_DTS := TQ210
+ DEVICE_TITLE := TQ210
+endef
+TARGET_DEVICES += tq210
+
+$(eval $(call BuildImage))