aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/samsung/Makefile
diff options
context:
space:
mode:
authorJianhui Zhao <jianhuizhao329@gmail.com>2018-04-17 11:09:14 +0800
committerJohn Crispin <john@phrozen.org>2018-07-30 14:10:00 +0200
commit84c212da44cf5df210ae166ed7e64adf764ccf3f (patch)
tree2351260a551bca0f71fbf482671a7da70d5842f0 /target/linux/samsung/Makefile
parent4caab808300ad75575d778bae6e184caa26aeabc (diff)
downloadupstream-84c212da44cf5df210ae166ed7e64adf764ccf3f.tar.gz
upstream-84c212da44cf5df210ae166ed7e64adf764ccf3f.tar.bz2
upstream-84c212da44cf5df210ae166ed7e64adf764ccf3f.zip
samsung/s5pv210: New target
Signed-off-by: Jianhui Zhao <jianhuizhao329@gmail.com>
Diffstat (limited to 'target/linux/samsung/Makefile')
-rw-r--r--target/linux/samsung/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/samsung/Makefile b/target/linux/samsung/Makefile
new file mode 100644
index 0000000000..9227503096
--- /dev/null
+++ b/target/linux/samsung/Makefile
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2018 Jianhui Zhao <jianhuizhao329@gmail.com>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=samsung
+BOARDNAME:=Samsung s3c24xx/s5pv210
+SUBTARGETS:=s5pv210
+MAINTAINER:=Jianhui Zhao <jianhuizhao329@gmail.com>
+
+KERNEL_PATCHVER:=4.14
+
+define Target/Description
+ Build firmware images for Samsung s3c24xx/s5pv210 based boards.
+endef
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=zImage dtbs
+
+$(eval $(call BuildTarget))