aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/s3c24xx/profiles
diff options
context:
space:
mode:
authorMirko Vogt <mirko@openwrt.org>2008-12-12 11:58:53 +0000
committerMirko Vogt <mirko@openwrt.org>2008-12-12 11:58:53 +0000
commit614683faf8029100802db06a825648d0b6490285 (patch)
tree7401b135dc7ce24ff0175e67e0f2ce7f96296ff0 /target/linux/s3c24xx/profiles
parent4a018d2445c5f249179ff82c8fffb0e3b717f738 (diff)
downloadupstream-614683faf8029100802db06a825648d0b6490285.tar.gz
upstream-614683faf8029100802db06a825648d0b6490285.tar.bz2
upstream-614683faf8029100802db06a825648d0b6490285.zip
changed Makefile and profiles, added patches for kernel 2.6.24 (stable-branch of Openmoko)
SVN-Revision: 13613
Diffstat (limited to 'target/linux/s3c24xx/profiles')
-rw-r--r--target/linux/s3c24xx/profiles/100-gta02-minimal.mk17
-rw-r--r--target/linux/s3c24xx/profiles/100-gta02.mk16
-rw-r--r--target/linux/s3c24xx/profiles/101-gta02-graphical.mk17
3 files changed, 34 insertions, 16 deletions
diff --git a/target/linux/s3c24xx/profiles/100-gta02-minimal.mk b/target/linux/s3c24xx/profiles/100-gta02-minimal.mk
new file mode 100644
index 0000000000..b252889b4e
--- /dev/null
+++ b/target/linux/s3c24xx/profiles/100-gta02-minimal.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/openmoko-gta02-minimal
+ NAME:=Openmoko GTA-02 (minimal)
+ PACKAGES:=
+endef
+
+define Profile/openmoko-gta02-minimal/Description
+ minimal Package set compatible with the Openmoko GTA-02 hardware
+endef
+$(eval $(call Profile,openmoko-gta02-minimal))
+
diff --git a/target/linux/s3c24xx/profiles/100-gta02.mk b/target/linux/s3c24xx/profiles/100-gta02.mk
deleted file mode 100644
index b5f59868bb..0000000000
--- a/target/linux/s3c24xx/profiles/100-gta02.mk
+++ /dev/null
@@ -1,16 +0,0 @@
-#
-# Copyright (C) 2008 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/openmoko-gta02
- NAME:=Openmoko GTA-02 (default)
-endef
-
-define Profile/openmoko-gta02/Description
- Package set compatible with the Openmoko GTA-02 hardware
-endef
-$(eval $(call Profile,openmoko-gta02))
-
diff --git a/target/linux/s3c24xx/profiles/101-gta02-graphical.mk b/target/linux/s3c24xx/profiles/101-gta02-graphical.mk
new file mode 100644
index 0000000000..a5c427e9a4
--- /dev/null
+++ b/target/linux/s3c24xx/profiles/101-gta02-graphical.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/openmoko-gta02-graphical
+ NAME:=Openmoko GTA-02 (graphical)
+ PACKAGES:=enlightenment xglamo
+endef
+
+define Profile/openmoko-gta02-graphical/Description
+ Package set with accelerated x11-environment compatible with the Openmoko GTA-02 hardware
+endef
+$(eval $(call Profile,openmoko-gta02-graphical))
+