aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-07-16 09:49:24 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-07-16 09:49:24 +0000
commit7df1d6160c5ae9151cb0a9bd25527d4a0e97fca9 (patch)
treebd5c2fbfd44bef195fb7d95c99bcb8d2eb378be8 /target/linux/rules.mk
parent37d93c17759f35adf0961900b3b2004efc51d565 (diff)
downloadupstream-7df1d6160c5ae9151cb0a9bd25527d4a0e97fca9.tar.gz
upstream-7df1d6160c5ae9151cb0a9bd25527d4a0e97fca9.tar.bz2
upstream-7df1d6160c5ae9151cb0a9bd25527d4a0e97fca9.zip
add modules.d to kernel modules
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1454 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/rules.mk')
-rw-r--r--target/linux/rules.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/target/linux/rules.mk b/target/linux/rules.mk
index 82ac46d58f..39afadb341 100644
--- a/target/linux/rules.mk
+++ b/target/linux/rules.mk
@@ -29,7 +29,13 @@ $$(PKG_$(1)): $(LINUX_DIR)/.modules_done
$(SCRIPT_DIR)/make-ipkg-dir.sh $$(I_$(1)) ../control/kmod-$(2).control $(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE) $(ARCH)
echo "Depends: $$(IDEPEND_$(1))" >> $$(I_$(1))/CONTROL/control
cp $(3) $$(I_$(1))/lib/modules/$(LINUX_VERSION)
- $(6)
+ifneq ($(6),)
+ mkdir -p $$(I_$(1))/etc/modules.d
+ for module in $(7); do \
+ echo $$$$module >> $$(I_$(1))/etc/modules.d/$(6)-$(2); \
+ done
+endif
+ $(8)
$(IPKG_BUILD) $$(I_$(1)) $(PACKAGE_DIR)
endef