aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rules.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-11-15 08:23:42 +0000
committerNicolas Thill <nico@openwrt.org>2005-11-15 08:23:42 +0000
commit58095e3bebf2dfce842149693ef07015844d3bbd (patch)
tree7861ac97ee68e4dba8c59d7775efdd0adfe4612c /target/linux/rules.mk
parent0e742821a57a67febacd2f28d06fab276d6fcf0e (diff)
downloadupstream-58095e3bebf2dfce842149693ef07015844d3bbd.tar.gz
upstream-58095e3bebf2dfce842149693ef07015844d3bbd.tar.bz2
upstream-58095e3bebf2dfce842149693ef07015844d3bbd.zip
fix kernel package and kernel modules dependency on it
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2492 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/rules.mk')
-rw-r--r--target/linux/rules.mk6
1 files changed, 1 insertions, 5 deletions
diff --git a/target/linux/rules.mk b/target/linux/rules.mk
index be151ea10f..8871fa442e 100644
--- a/target/linux/rules.mk
+++ b/target/linux/rules.mk
@@ -17,11 +17,7 @@ else
KDEPEND_$(1):=$($(4))
endif
-ifeq ($$(strip $(5)),)
-IDEPEND_$(1):=kernel-$(LINUX_VERSION)-$(BOARD) ($(PKG_RELEASE))
-else
-IDEPEND_$(1):=kernel-$(LINUX_VERSION)-$(BOARD) ($(PKG_RELEASE)), $(5)
-endif
+IDEPEND_$(1):=kernel ($(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)) $(foreach pkg,$(5),", $(pkg)")
PKG_$(1) := $(PACKAGE_DIR)/kmod-$(2)_$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)_$(ARCH).ipk
I_$(1) := $(PKG_BUILD_DIR)/ipkg/$(2)