aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-06-11 15:36:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-06-11 15:36:31 +0000
commitbc4ba23f31108bcbc47e24851f3ddd60aa20ffa7 (patch)
tree0300926e797cd18b6c5c17d55456d312f62e21ed /target/linux/rules.mk
parent5027d70cff542cf047bd5e40ced3fbce4a10278e (diff)
downloadupstream-bc4ba23f31108bcbc47e24851f3ddd60aa20ffa7.tar.gz
upstream-bc4ba23f31108bcbc47e24851f3ddd60aa20ffa7.tar.bz2
upstream-bc4ba23f31108bcbc47e24851f3ddd60aa20ffa7.zip
add board tag to kernel module version and add versioned depend (does not work with current ipkg yet)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1202 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/rules.mk')
-rw-r--r--target/linux/rules.mk12
1 files changed, 10 insertions, 2 deletions
diff --git a/target/linux/rules.mk b/target/linux/rules.mk
index 451ec26e42..9446c343fa 100644
--- a/target/linux/rules.mk
+++ b/target/linux/rules.mk
@@ -5,7 +5,13 @@ else
KDEPEND_$(1):=$($(4))
endif
-PKG_$(1) := $(PACKAGE_DIR)/kmod-$(2)_$(LINUX_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
+ifeq ($$(strip $(5)),)
+IDEPEND_$(1):=kernel ($(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE))
+else
+IDEPEND_$(1):=kernel ($(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)), $(5)
+endif
+
+PKG_$(1) := $(PACKAGE_DIR)/kmod-$(2)_$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)_$(ARCH).ipk
I_$(1) := $(PKG_BUILD_DIR)/ipkg/$(2)
ifeq ($$(KDEPEND_$(1)),m)
@@ -18,8 +24,10 @@ endif
endif
$$(PKG_$(1)): $(LINUX_DIR)/.modules_done
+ rm -rf $$(I_$(1))
mkdir -p $$(I_$(1))/lib/modules/$(LINUX_VERSION)
- $(SCRIPT_DIR)/make-ipkg-dir.sh $$(I_$(1)) ../control/kmod-$(2).control $(LINUX_VERSION)-$(PKG_RELEASE) $(ARCH)
+ $(SCRIPT_DIR)/make-ipkg-dir.sh $$(I_$(1)) ../control/kmod-$(2).control $(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE) $(ARCH)
+ echo "Depends: $$(IDEPEND_$(1))" >> $$(I_$(1))/CONTROL/control
cp $(3) $$(I_$(1))/lib/modules/$(LINUX_VERSION)
$(IPKG_BUILD) $$(I_$(1)) $(PACKAGE_DIR)