aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-05-30 19:38:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-05-30 19:38:38 +0000
commit340f1875ed67c4df30612f9fcd86b6fe9307c77a (patch)
treeeb392a5dc848616550a5c47b5a2481f8e6b8bc1f /target/linux/rules.mk
parentf45baccdc5081fc6245c9d567ddb47518f3dc84b (diff)
downloadupstream-340f1875ed67c4df30612f9fcd86b6fe9307c77a.tar.gz
upstream-340f1875ed67c4df30612f9fcd86b6fe9307c77a.tar.bz2
upstream-340f1875ed67c4df30612f9fcd86b6fe9307c77a.zip
resync with kamikaze
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3844 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/rules.mk')
-rw-r--r--target/linux/rules.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/rules.mk b/target/linux/rules.mk
index 8490d110de..da32ed8b04 100644
--- a/target/linux/rules.mk
+++ b/target/linux/rules.mk
@@ -20,6 +20,7 @@ LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
-e 's/mipseb/mips/' \
-e 's/powerpc/ppc/' \
-e 's/sh[234]/sh/' \
+ -e 's/armeb/arm/' \
)
KPKG_MAKEOPTS:= IPKG="$(IPKG_KERNEL)" \
@@ -75,6 +76,11 @@ ifneq ($(6),)
for module in $(7); do \
echo $$$$module >> $$(I_$(1))/etc/modules.d/$(6)-$(2); \
done
+ echo "#!/bin/sh" >> $$(I_$(1))/CONTROL/postinst
+ echo "[ -z \"\$$$$IPKG_INSTROOT\" ] || exit" >> $$(I_$(1))/CONTROL/postinst
+ echo ". /etc/functions.sh" >> $$(I_$(1))/CONTROL/postinst
+ echo "load_modules /etc/modules.d/$(6)-$(2)" >> $$(I_$(1))/CONTROL/postinst
+ chmod 0755 $$(I_$(1))/CONTROL/postinst
endif
$(8)
$(IPKG_BUILD) $$(I_$(1)) $(PACKAGE_DIR)