aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rtl838x/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2020-10-19 14:47:45 +0200
committerJohn Crispin <john@phrozen.org>2020-10-19 14:53:27 +0200
commitc78e123d5a5e7c3baa74f326613a14f7e99a29a3 (patch)
treee7d9504aa5c775700eeb278a832913e41274377a /target/linux/rtl838x/Makefile
parent7f5f738466aca2cd8f5daf73f68f4d32b70d43b5 (diff)
downloadupstream-c78e123d5a5e7c3baa74f326613a14f7e99a29a3.tar.gz
upstream-c78e123d5a5e7c3baa74f326613a14f7e99a29a3.tar.bz2
upstream-c78e123d5a5e7c3baa74f326613a14f7e99a29a3.zip
rtl838x: various fixes
* add d-link_dgs-1210-10p support * make sure mips16 is disabled * add a generic sub target * add proper cflags Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/rtl838x/Makefile')
-rw-r--r--target/linux/rtl838x/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/rtl838x/Makefile b/target/linux/rtl838x/Makefile
index c4138c7a9a..83cb074b89 100644
--- a/target/linux/rtl838x/Makefile
+++ b/target/linux/rtl838x/Makefile
@@ -9,6 +9,7 @@ BOARD:=rtl838x
BOARDNAME:=Realtek MIPS
DEVICE_TYPE:=basic
FEATURES:=ramdisk squashfs
+SUBTARGETS:=generic
KERNEL_PATCHVER:=5.4
@@ -18,6 +19,8 @@ endef
include $(INCLUDE_DIR)/target.mk
+FEATURES := $(filter-out mips16,$(FEATURES))
+
DEFAULT_PACKAGES += swconfig uboot-envtools ethtool kmod-gpio-button-hotplug
$(eval $(call BuildTarget))