aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rockchip/image/armv8.mk
diff options
context:
space:
mode:
authorTobias Mädel <t.maedel@alfeld.de>2020-04-12 13:57:25 +0200
committerPetr Štetiar <ynezz@true.cz>2020-04-20 16:37:56 +0200
commit6a05a85dcbf91777a3666693b41bd71dee6d9bfd (patch)
tree1871e9340a4e1a40818bae4112e047ef0fca6dcc /target/linux/rockchip/image/armv8.mk
parent797506011695d2dacba74bec717fbf88a7729ace (diff)
downloadupstream-6a05a85dcbf91777a3666693b41bd71dee6d9bfd.tar.gz
upstream-6a05a85dcbf91777a3666693b41bd71dee6d9bfd.tar.bz2
upstream-6a05a85dcbf91777a3666693b41bd71dee6d9bfd.zip
rockchip: add support for Pine64 RockPro64
This adds the new rockchip target and support for RockPro64 RK3399 Flash: 16 MiB SPI NOR RAM: 2 GiB/4 GiB LPDDR4 SoC: RK3399 USB: 2x USB 2.0, 1x USB 3.0, 1x USB-C Ethernet: 1x GbE PCIe: PCIe 2.0, 4 lanes Storage: eMMC or SD card Optional SDIO wifi/bt module The Pine64 RockPro64 is a single-board-computer with a 4x PCIe connector, 6 ARM64 cores (4 little, 2 big), plenty of RAM and storage. By default the single Gigabit-Ethernet port is configured as the LAN port. Installation of the firware is possible by dd'ing the image to an SD card or the eMMC flash. Serial: 3v3 1500000 8n1 U-boot is build from the mainline tree and integrated into the images. Required ATF to build u-boot is downloaded from a CI build bot. Signed-off-by: Tobias Mädel <t.maedel@alfeld.de> Tested-by: Tobias Schramm <t.schramm@manjaro.org>
Diffstat (limited to 'target/linux/rockchip/image/armv8.mk')
-rw-r--r--target/linux/rockchip/image/armv8.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/rockchip/image/armv8.mk b/target/linux/rockchip/image/armv8.mk
new file mode 100644
index 0000000000..737c6e4f9a
--- /dev/null
+++ b/target/linux/rockchip/image/armv8.mk
@@ -0,0 +1,14 @@
+#
+# Copyright (C) 2020 Tobias Maedel
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+define Device/pine64_rockpro64
+ DEVICE_VENDOR := Pine64
+ DEVICE_MODEL := RockPro64
+ SOC := rk3399
+ UBOOT_DEVICE_NAME := rockpro64-rk3399
+ IMAGE/sysupgrade.img.gz := boot-common | boot-script | pine64-img | gzip | append-metadata
+endef
+TARGET_DEVICES += pine64_rockpro64