aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rockchip/image/Makefile
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2023-05-13 12:34:45 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2023-05-18 17:42:53 +0200
commitafff2feb28baecaaf368002d819fb63973cf778a (patch)
treeb99705fbc3bd358f555484934eff0d20f4d900bf /target/linux/rockchip/image/Makefile
parente35c7ab51fd161724924321f0590a9e26cb24aa7 (diff)
downloadupstream-afff2feb28baecaaf368002d819fb63973cf778a.tar.gz
upstream-afff2feb28baecaaf368002d819fb63973cf778a.tar.bz2
upstream-afff2feb28baecaaf368002d819fb63973cf778a.zip
rockchip: move UBOOT_DEVICE_NAME to default
Simplify variable usage. Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
Diffstat (limited to 'target/linux/rockchip/image/Makefile')
-rw-r--r--target/linux/rockchip/image/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/rockchip/image/Makefile b/target/linux/rockchip/image/Makefile
index e232166e51..3b118201b6 100644
--- a/target/linux/rockchip/image/Makefile
+++ b/target/linux/rockchip/image/Makefile
@@ -50,6 +50,7 @@ define Device/Default
KERNEL = kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb
IMAGES := sysupgrade.img.gz
DEVICE_DTS = rockchip/$$(SOC)-$(lastword $(subst _, ,$(1)))
+ UBOOT_DEVICE_NAME = $(lastword $(subst _, ,$(1)))-$$(SOC)
endef
include $(SUBTARGET).mk