aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rockchip/image/Makefile
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2022-11-13 21:29:26 +0800
committerChuanhong Guo <gch981213@gmail.com>2022-11-14 22:50:21 +0800
commitc984fc762412f206ebeb3e873742988ff760fb90 (patch)
treedee0a969f2fcf96d81804a5bc6a2b468826092a2 /target/linux/rockchip/image/Makefile
parent6fdeb48c1ec207e7952bfff1596b65626fb336fd (diff)
downloadupstream-c984fc762412f206ebeb3e873742988ff760fb90.tar.gz
upstream-c984fc762412f206ebeb3e873742988ff760fb90.tar.bz2
upstream-c984fc762412f206ebeb3e873742988ff760fb90.zip
rockchip: use LZMA FIT for kernel image
Use LZMA compressed kernel to save some space in boot partition. Fixes: #11197 Tested-by: Tianling Shen <cnsztl@immortalwrt.org> [NanoPi R2S] Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/rockchip/image/Makefile')
-rw-r--r--target/linux/rockchip/image/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/target/linux/rockchip/image/Makefile b/target/linux/rockchip/image/Makefile
index e4db1e5d58..e232166e51 100644
--- a/target/linux/rockchip/image/Makefile
+++ b/target/linux/rockchip/image/Makefile
@@ -16,7 +16,6 @@ define Build/boot-common
rm -fR $@.boot
mkdir -p $@.boot
- $(CP) $(DTS_DIR)/$(DEVICE_DTS).dtb $@.boot/rockchip.dtb
$(CP) $(IMAGE_KERNEL) $@.boot/kernel.img
endef
@@ -48,7 +47,7 @@ endef
### Devices ###
define Device/Default
PROFILES := Default
- KERNEL := kernel-bin
+ KERNEL = kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb
IMAGES := sysupgrade.img.gz
DEVICE_DTS = rockchip/$$(SOC)-$(lastword $(subst _, ,$(1)))
endef