aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rockchip/Makefile
diff options
context:
space:
mode:
authorTobias Mädel <t.maedel@alfeld.de>2020-04-12 13:57:25 +0200
committerPetr Štetiar <ynezz@true.cz>2020-04-20 16:37:56 +0200
commit6a05a85dcbf91777a3666693b41bd71dee6d9bfd (patch)
tree1871e9340a4e1a40818bae4112e047ef0fca6dcc /target/linux/rockchip/Makefile
parent797506011695d2dacba74bec717fbf88a7729ace (diff)
downloadupstream-6a05a85dcbf91777a3666693b41bd71dee6d9bfd.tar.gz
upstream-6a05a85dcbf91777a3666693b41bd71dee6d9bfd.tar.bz2
upstream-6a05a85dcbf91777a3666693b41bd71dee6d9bfd.zip
rockchip: add support for Pine64 RockPro64
This adds the new rockchip target and support for RockPro64 RK3399 Flash: 16 MiB SPI NOR RAM: 2 GiB/4 GiB LPDDR4 SoC: RK3399 USB: 2x USB 2.0, 1x USB 3.0, 1x USB-C Ethernet: 1x GbE PCIe: PCIe 2.0, 4 lanes Storage: eMMC or SD card Optional SDIO wifi/bt module The Pine64 RockPro64 is a single-board-computer with a 4x PCIe connector, 6 ARM64 cores (4 little, 2 big), plenty of RAM and storage. By default the single Gigabit-Ethernet port is configured as the LAN port. Installation of the firware is possible by dd'ing the image to an SD card or the eMMC flash. Serial: 3v3 1500000 8n1 U-boot is build from the mainline tree and integrated into the images. Required ATF to build u-boot is downloaded from a CI build bot. Signed-off-by: Tobias Mädel <t.maedel@alfeld.de> Tested-by: Tobias Schramm <t.schramm@manjaro.org>
Diffstat (limited to 'target/linux/rockchip/Makefile')
-rw-r--r--target/linux/rockchip/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/rockchip/Makefile b/target/linux/rockchip/Makefile
new file mode 100644
index 0000000000..41f0560bac
--- /dev/null
+++ b/target/linux/rockchip/Makefile
@@ -0,0 +1,24 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+BOARD:=rockchip
+BOARDNAME:=Rockchip
+FEATURES:=ext4 audio usb usbgadget display gpio fpu rootfs-part boot-part squashfs
+SUBTARGETS:=armv8
+
+KERNEL_PATCHVER=5.4
+
+define Target/Description
+ Build firmware image for Rockchip SoC devices.
+endef
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += uboot-envtools partx-utils e2fsprogs mkf2fs
+
+KERNELNAME:=Image dtbs
+
+$(eval $(call BuildTarget))