aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realview/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-09-14 20:10:04 +0000
committerJohn Crispin <john@openwrt.org>2015-09-14 20:10:04 +0000
commitf582a93a6ae52c1dd5595f6add425f570f2ca667 (patch)
treecad9b2cf0511d6152a496008d6e4327186ad1242 /target/linux/realview/image/Makefile
parentedb5ec3f34bca0a674ff076f3573be86b67942e6 (diff)
downloadupstream-f582a93a6ae52c1dd5595f6add425f570f2ca667.tar.gz
upstream-f582a93a6ae52c1dd5595f6add425f570f2ca667.tar.bz2
upstream-f582a93a6ae52c1dd5595f6add425f570f2ca667.zip
realview: create sd card image for qemu
enables a real rootfs with custom size use qemu with: qemu-system-arm -M realview-pbx-a9 \ -kernel openwrt-realview-vmlinux.elf \ -nographic -m 1024M \ -sd openwrt-realview-sdcard.img \ --append "console=ttyAMA0 root=/dev/mmcblk0p1" modified script from brcm2708 target Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> SVN-Revision: 46924
Diffstat (limited to 'target/linux/realview/image/Makefile')
-rw-r--r--target/linux/realview/image/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/realview/image/Makefile b/target/linux/realview/image/Makefile
index 28db6f330c..ad7aa6951c 100644
--- a/target/linux/realview/image/Makefile
+++ b/target/linux/realview/image/Makefile
@@ -21,7 +21,16 @@ endef
define Image/Build
$(call Image/Build/$(1))
+ $(call Build/sdcard-img)
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
endef
+define Build/sdcard-img
+ ./gen_realview_sdcard_img.sh \
+ $(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE)sdcard.img \
+ $(KDIR)/root.ext4 \
+ $(CONFIG_TARGET_ROOTFS_PARTSIZE)
+endef
+
+
$(eval $(call BuildImage))