aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2023-01-04 14:53:54 +0100
committerSander Vanheule <sander@svanheule.net>2023-01-05 21:59:20 +0100
commit44e07852856e65d4348185ed8042fa8a8c05530f (patch)
tree6fe4a3f43f00c6ae8b3be8cfb1aed21793bb053d /target/linux/realtek
parent87b9825521b846e2fc25b1ba683354410307f84b (diff)
downloadupstream-44e07852856e65d4348185ed8042fa8a8c05530f.tar.gz
upstream-44e07852856e65d4348185ed8042fa8a8c05530f.tar.bz2
upstream-44e07852856e65d4348185ed8042fa8a8c05530f.zip
realtek: Migrate to upstream generic MIPS addresses
Upstream generic MIPS uses 0x80100000 and 0x80100400 for the LOADADDR and ENTRY addresses. As we do not want to diverge from upstream and patch upstream when not needed, adjust our addresses as well to be future proof. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl> Tested-by: Jan Hoffmann <jan@3e8.eu> # HPE 1920-8G, HPE 1920-48G
Diffstat (limited to 'target/linux/realtek')
-rw-r--r--target/linux/realtek/files-5.10/arch/mips/rtl838x/Platform2
-rw-r--r--target/linux/realtek/files-5.15/arch/mips/rtl838x/Platform2
-rw-r--r--target/linux/realtek/image/Makefile4
3 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/realtek/files-5.10/arch/mips/rtl838x/Platform b/target/linux/realtek/files-5.10/arch/mips/rtl838x/Platform
index 9d45d2ddd5..98f18cac1b 100644
--- a/target/linux/realtek/files-5.10/arch/mips/rtl838x/Platform
+++ b/target/linux/realtek/files-5.10/arch/mips/rtl838x/Platform
@@ -2,4 +2,4 @@
# Realtek RTL838x SoCs
#
cflags-$(CONFIG_RTL83XX) += -I$(srctree)/arch/mips/include/asm/mach-rtl838x/
-load-$(CONFIG_RTL83XX) += 0xffffffff80000000
+load-$(CONFIG_RTL83XX) += 0xffffffff80100000
diff --git a/target/linux/realtek/files-5.15/arch/mips/rtl838x/Platform b/target/linux/realtek/files-5.15/arch/mips/rtl838x/Platform
index 9d45d2ddd5..98f18cac1b 100644
--- a/target/linux/realtek/files-5.15/arch/mips/rtl838x/Platform
+++ b/target/linux/realtek/files-5.15/arch/mips/rtl838x/Platform
@@ -2,4 +2,4 @@
# Realtek RTL838x SoCs
#
cflags-$(CONFIG_RTL83XX) += -I$(srctree)/arch/mips/include/asm/mach-rtl838x/
-load-$(CONFIG_RTL83XX) += 0xffffffff80000000
+load-$(CONFIG_RTL83XX) += 0xffffffff80100000
diff --git a/target/linux/realtek/image/Makefile b/target/linux/realtek/image/Makefile
index 7c5b67191c..82390212e6 100644
--- a/target/linux/realtek/image/Makefile
+++ b/target/linux/realtek/image/Makefile
@@ -3,8 +3,8 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-KERNEL_LOADADDR = 0x80000000
-KERNEL_ENTRY = 0x80000400
+KERNEL_LOADADDR = 0x80100000
+KERNEL_ENTRY = 0x80100400
DEVICE_VARS += \
CAMEO_BOARD_VERSION \