aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2023-04-30 14:32:03 +0100
committerDaniel Golle <daniel@makrotopia.org>2023-05-24 19:26:52 +0100
commitf7d0a4797feaee0c03d3f1cd5459702b13337ba2 (patch)
treeea7221cff6439df88270ab225e9f6569ee237123 /target/linux/realtek
parent5970f5d02764fa414660f773e8e7556c69577195 (diff)
downloadupstream-f7d0a4797feaee0c03d3f1cd5459702b13337ba2.tar.gz
upstream-f7d0a4797feaee0c03d3f1cd5459702b13337ba2.tar.bz2
upstream-f7d0a4797feaee0c03d3f1cd5459702b13337ba2.zip
generic: mt7530: backport support for the MT7988 built-in switch
Backport commits adding support for the MT7988 built-in switch to the mt7530 driver. This change results in the Kconfig symbol NET_DSA_MT7530 to be extended by NET_DSA_MT7530_MDIO (everything formally covered by NET_DSA_MT7530) and NET_DSA_MT7530_MMIO (a new driver for the MMIO-connected built-in switch of the MT7988 SoC). Select NET_DSA_MT7530_MDIO for all targets previously selecting NET_DSA_MT7530, with the exception of mediatek/filogic which also selects NET_DSA_MT7530_MMIO. Signed-off-by: Daniel Golle <daniel@makrotopia.org> (cherry picked from commit 958fdf36e35c814eb83faf2c39db4ca379c921b5)
Diffstat (limited to 'target/linux/realtek')
-rw-r--r--target/linux/realtek/patches-5.15/008-5.17-watchdog-add-realtek-otto-watchdog-timer.patch2
-rw-r--r--target/linux/realtek/patches-5.15/700-net-dsa-add-support-for-rtl838x-switch.patch4
2 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/realtek/patches-5.15/008-5.17-watchdog-add-realtek-otto-watchdog-timer.patch b/target/linux/realtek/patches-5.15/008-5.17-watchdog-add-realtek-otto-watchdog-timer.patch
index e562dd8396..17ff729f52 100644
--- a/target/linux/realtek/patches-5.15/008-5.17-watchdog-add-realtek-otto-watchdog-timer.patch
+++ b/target/linux/realtek/patches-5.15/008-5.17-watchdog-add-realtek-otto-watchdog-timer.patch
@@ -32,7 +32,7 @@ Signed-off-by: Guenter Roeck <linux@roeck-us.net>
--- a/MAINTAINERS
+++ b/MAINTAINERS
-@@ -15899,6 +15899,13 @@ S: Maintained
+@@ -15902,6 +15902,13 @@ S: Maintained
F: include/sound/rt*.h
F: sound/soc/codecs/rt*
diff --git a/target/linux/realtek/patches-5.15/700-net-dsa-add-support-for-rtl838x-switch.patch b/target/linux/realtek/patches-5.15/700-net-dsa-add-support-for-rtl838x-switch.patch
index 8f40001263..8c6a4c3639 100644
--- a/target/linux/realtek/patches-5.15/700-net-dsa-add-support-for-rtl838x-switch.patch
+++ b/target/linux/realtek/patches-5.15/700-net-dsa-add-support-for-rtl838x-switch.patch
@@ -22,7 +22,7 @@ Submitted-by: John Crispin <john@phrozen.org>
--- a/drivers/net/dsa/Kconfig
+++ b/drivers/net/dsa/Kconfig
-@@ -61,6 +61,8 @@ source "drivers/net/dsa/sja1105/Kconfig"
+@@ -85,6 +85,8 @@ source "drivers/net/dsa/sja1105/Kconfig"
source "drivers/net/dsa/xrs700x/Kconfig"
@@ -33,7 +33,7 @@ Submitted-by: John Crispin <john@phrozen.org>
select NET_DSA_TAG_RTL4_A
--- a/drivers/net/dsa/Makefile
+++ b/drivers/net/dsa/Makefile
-@@ -22,5 +22,6 @@ obj-y += microchip/
+@@ -24,5 +24,6 @@ obj-y += microchip/
obj-y += mv88e6xxx/
obj-y += ocelot/
obj-y += qca/