aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek/patches-5.4
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2022-02-05 17:14:17 +0000
committerDaniel Golle <daniel@makrotopia.org>2022-02-17 15:21:46 +0000
commit58b82e6ca503aea3f67b4692f2c3196cb0a2ca2c (patch)
treea632ebec6adbc74187badde0c619561a7ec0465e /target/linux/realtek/patches-5.4
parent397de500896f3c7c4e2468c21521502392af4574 (diff)
downloadupstream-58b82e6ca503aea3f67b4692f2c3196cb0a2ca2c.tar.gz
upstream-58b82e6ca503aea3f67b4692f2c3196cb0a2ca2c.tar.bz2
upstream-58b82e6ca503aea3f67b4692f2c3196cb0a2ca2c.zip
realtek: drop support for Linux 5.4
Drop patches and files for Linux 5.4 now that we've been using 5.10 for a while and support for Linux 5.4 has gone out-of-sync. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/realtek/patches-5.4')
-rw-r--r--target/linux/realtek/patches-5.4/300-mips-add-rtl838x-platform.patch39
-rw-r--r--target/linux/realtek/patches-5.4/301-gpio-add-rtl838x-driver.patch32
-rw-r--r--target/linux/realtek/patches-5.4/302-clocksource-add-rtl9300-driver.patch34
-rw-r--r--target/linux/realtek/patches-5.4/400-mtd-add-rtl838x-spi-flash-driver.patch23
-rw-r--r--target/linux/realtek/patches-5.4/700-net-dsa-add-support-for-rtl838x-switch.patch18
-rw-r--r--target/linux/realtek/patches-5.4/701-net-dsa-add-rtl838x-support-for-tag-trailer.patch40
-rw-r--r--target/linux/realtek/patches-5.4/702-net-dsa-increase-dsa-max-ports-for-rtl838x.patch11
-rw-r--r--target/linux/realtek/patches-5.4/702-net-ethernet-add-support-for-rtl838x-ethernet.patch26
-rw-r--r--target/linux/realtek/patches-5.4/703-include-linux-add-phy-ops-for-rtl838x.patch13
-rw-r--r--target/linux/realtek/patches-5.4/704-drivers-net-phy-eee-support-for-rtl838x.patch41
-rw-r--r--target/linux/realtek/patches-5.4/705-add-rtl-phy.patch25
-rw-r--r--target/linux/realtek/patches-5.4/705-include-linux-phy-increase-phy-address-number-for-rtl839x.patch11
12 files changed, 0 insertions, 313 deletions
diff --git a/target/linux/realtek/patches-5.4/300-mips-add-rtl838x-platform.patch b/target/linux/realtek/patches-5.4/300-mips-add-rtl838x-platform.patch
deleted file mode 100644
index b47f6f5ffa..0000000000
--- a/target/linux/realtek/patches-5.4/300-mips-add-rtl838x-platform.patch
+++ /dev/null
@@ -1,39 +0,0 @@
---- a/arch/mips/Kbuild.platforms
-+++ b/arch/mips/Kbuild.platforms
-@@ -27,6 +27,7 @@ platforms += pistachio
- platforms += pmcs-msp71xx
- platforms += pnx833x
- platforms += ralink
-+platforms += rtl838x
- platforms += rb532
- platforms += sgi-ip22
- platforms += sgi-ip27
---- a/arch/mips/Kconfig
-+++ b/arch/mips/Kconfig
-@@ -636,6 +636,26 @@ config RALINK
- select ARCH_HAS_RESET_CONTROLLER
- select RESET_CONTROLLER
-
-+config RTL838X
-+ bool "Realtek based platforms"
-+ select DMA_NONCOHERENT
-+ select IRQ_MIPS_CPU
-+ select CSRC_R4K
-+ select CEVT_R4K
-+ select SYS_HAS_CPU_MIPS32_R1
-+ select SYS_HAS_CPU_MIPS32_R2
-+ select SYS_SUPPORTS_BIG_ENDIAN
-+ select SYS_SUPPORTS_32BIT_KERNEL
-+ select SYS_SUPPORTS_MIPS16
-+ select SYS_HAS_EARLY_PRINTK
-+ select SYS_HAS_EARLY_PRINTK_8250
-+ select USE_GENERIC_EARLY_PRINTK_8250
-+ select BOOT_RAW
-+ select PINCTRL
-+ select ARCH_HAS_RESET_CONTROLLER
-+ select RESET_CONTROLLER
-+ select USE_OF
-+
- config SGI_IP22
- bool "SGI IP22 (Indy/Indigo2)"
- select FW_ARC
diff --git a/target/linux/realtek/patches-5.4/301-gpio-add-rtl838x-driver.patch b/target/linux/realtek/patches-5.4/301-gpio-add-rtl838x-driver.patch
deleted file mode 100644
index 4f5901d87f..0000000000
--- a/target/linux/realtek/patches-5.4/301-gpio-add-rtl838x-driver.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- a/drivers/gpio/Kconfig
-+++ b/drivers/gpio/Kconfig
-@@ -441,6 +441,18 @@ config GPIO_REG
- A 32-bit single register GPIO fixed in/out implementation. This
- can be used to represent any register as a set of GPIO signals.
-
-+config GPIO_RTL8231
-+ tristate "RTL8231 GPIO"
-+ depends on GPIO_RTL838X
-+ help
-+ Say yes here to support Realtek RTL8231 GPIO expansion chips.
-+
-+config GPIO_RTL838X
-+ tristate "RTL838X GPIO"
-+ depends on RTL838X
-+ help
-+ Say yes here to support RTL838X GPIO devices.
-+
- config GPIO_SAMA5D2_PIOBU
- tristate "SAMA5D2 PIOBU GPIO support"
- depends on MFD_SYSCON
---- a/drivers/gpio/Makefile
-+++ b/drivers/gpio/Makefile
-@@ -117,6 +117,8 @@ obj-$(CONFIG_GPIO_RC5T583) += gpio-rc5t
- obj-$(CONFIG_GPIO_RCAR) += gpio-rcar.o
- obj-$(CONFIG_GPIO_RDC321X) += gpio-rdc321x.o
- obj-$(CONFIG_GPIO_REG) += gpio-reg.o
-+obj-$(CONFIG_GPIO_RTL8231) += gpio-rtl8231.o
-+obj-$(CONFIG_GPIO_RTL838X) += gpio-rtl838x.o
- obj-$(CONFIG_ARCH_SA1100) += gpio-sa1100.o
- obj-$(CONFIG_GPIO_SAMA5D2_PIOBU) += gpio-sama5d2-piobu.o
- obj-$(CONFIG_GPIO_SCH311X) += gpio-sch311x.o
diff --git a/target/linux/realtek/patches-5.4/302-clocksource-add-rtl9300-driver.patch b/target/linux/realtek/patches-5.4/302-clocksource-add-rtl9300-driver.patch
deleted file mode 100644
index db8f22bf02..0000000000
--- a/target/linux/realtek/patches-5.4/302-clocksource-add-rtl9300-driver.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- a/drivers/clocksource/Kconfig
-+++ b/drivers/clocksource/Kconfig
-@@ -128,6 +128,15 @@ config RDA_TIMER
- help
- Enables the support for the RDA Micro timer driver.
-
-+config RTL9300_TIMER
-+ bool "Clocksource/timer for the Realtek RTL9300 family of SoCs"
-+ depends on MIPS
-+ select COMMON_CLK
-+ select TIMER_OF
-+ select CLKSRC_MMIO
-+ help
-+ Enables support for the Realtek RTL9300 timer driver.
-+
- config SUN4I_TIMER
- bool "Sun4i timer driver" if COMPILE_TEST
- depends on HAS_IOMEM
-@@ -697,5 +706,4 @@ config INGENIC_TIMER
- select IRQ_DOMAIN
- help
- Support for the timer/counter unit of the Ingenic JZ SoCs.
--
- endmenu
---- a/drivers/clocksource/Makefile
-+++ b/drivers/clocksource/Makefile
-@@ -61,6 +61,7 @@ obj-$(CONFIG_MILBEAUT_TIMER) += timer-mi
- obj-$(CONFIG_SPRD_TIMER) += timer-sprd.o
- obj-$(CONFIG_NPCM7XX_TIMER) += timer-npcm7xx.o
- obj-$(CONFIG_RDA_TIMER) += timer-rda.o
-+obj-$(CONFIG_RTL9300_TIMER) += timer-rtl9300.o
-
- obj-$(CONFIG_ARC_TIMERS) += arc_timer.o
- obj-$(CONFIG_ARM_ARCH_TIMER) += arm_arch_timer.o
diff --git a/target/linux/realtek/patches-5.4/400-mtd-add-rtl838x-spi-flash-driver.patch b/target/linux/realtek/patches-5.4/400-mtd-add-rtl838x-spi-flash-driver.patch
deleted file mode 100644
index 16cff75308..0000000000
--- a/target/linux/realtek/patches-5.4/400-mtd-add-rtl838x-spi-flash-driver.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/drivers/mtd/spi-nor/Kconfig
-+++ b/drivers/mtd/spi-nor/Kconfig
-@@ -118,4 +118,13 @@ config SPI_INTEL_SPI_PLATFORM
- To compile this driver as a module, choose M here: the module
- will be called intel-spi-platform.
-
-+config SPI_RTL838X
-+ tristate "Realtek RTl838X SPI flash platform driver"
-+ depends on RTL838X
-+ help
-+ This driver provides support for accessing SPI flash
-+ in the RTL838X SoC.
-+
-+ Say N here unless you know what you are doing.
-+
- endif # MTD_SPI_NOR
---- a/drivers/mtd/spi-nor/Makefile
-+++ b/drivers/mtd/spi-nor/Makefile
-@@ -8,3 +8,4 @@ obj-$(CONFIG_SPI_NXP_SPIFI) += nxp-spifi
- obj-$(CONFIG_SPI_INTEL_SPI) += intel-spi.o
- obj-$(CONFIG_SPI_INTEL_SPI_PCI) += intel-spi-pci.o
- obj-$(CONFIG_SPI_INTEL_SPI_PLATFORM) += intel-spi-platform.o
-+obj-$(CONFIG_SPI_RTL838X) += rtl838x-nor.o
diff --git a/target/linux/realtek/patches-5.4/700-net-dsa-add-support-for-rtl838x-switch.patch b/target/linux/realtek/patches-5.4/700-net-dsa-add-support-for-rtl838x-switch.patch
deleted file mode 100644
index bb6f83e55d..0000000000
--- a/target/linux/realtek/patches-5.4/700-net-dsa-add-support-for-rtl838x-switch.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/drivers/net/dsa/Kconfig
-+++ b/drivers/net/dsa/Kconfig
-@@ -63,6 +63,8 @@ config NET_DSA_QCA8K
- This enables support for the Qualcomm Atheros QCA8K Ethernet
- switch chips.
-
-+source "drivers/net/dsa/rtl83xx/Kconfig"
-+
- config NET_DSA_REALTEK_SMI
- tristate "Realtek SMI Ethernet switch family support"
- depends on NET_DSA
---- a/drivers/net/dsa/Makefile
-+++ b/drivers/net/dsa/Makefile
-@@ -21,3 +21,4 @@ obj-y += b53/
- obj-y += microchip/
- obj-y += mv88e6xxx/
- obj-y += sja1105/
-+obj-y += rtl83xx/
diff --git a/target/linux/realtek/patches-5.4/701-net-dsa-add-rtl838x-support-for-tag-trailer.patch b/target/linux/realtek/patches-5.4/701-net-dsa-add-rtl838x-support-for-tag-trailer.patch
deleted file mode 100644
index 803614e7c0..0000000000
--- a/target/linux/realtek/patches-5.4/701-net-dsa-add-rtl838x-support-for-tag-trailer.patch
+++ /dev/null
@@ -1,40 +0,0 @@
---- a/net/dsa/tag_trailer.c
-+++ b/net/dsa/tag_trailer.c
-@@ -44,7 +44,12 @@ static struct sk_buff *trailer_xmit(stru
-
- trailer = skb_put(nskb, 4);
- trailer[0] = 0x80;
-+
-+#ifdef CONFIG_NET_DSA_RTL83XX
-+ trailer[1] = dp->index;
-+#else
- trailer[1] = 1 << dp->index;
-+#endif /* CONFIG_NET_DSA_RTL838X */
- trailer[2] = 0x10;
- trailer[3] = 0x00;
-
-@@ -61,12 +66,23 @@ static struct sk_buff *trailer_rcv(struc
- return NULL;
-
- trailer = skb_tail_pointer(skb) - 4;
-+
-+#ifdef CONFIG_NET_DSA_RTL83XX
-+ if (trailer[0] != 0x80 || (trailer[1] & 0x80) != 0x00 ||
-+ (trailer[2] & 0xef) != 0x00 || trailer[3] != 0x00)
-+ return NULL;
-+
-+ if (trailer[1] & 0x40)
-+ skb->offload_fwd_mark = 1;
-+
-+ source_port = trailer[1] & 0x3f;
-+#else
- if (trailer[0] != 0x80 || (trailer[1] & 0xf8) != 0x00 ||
- (trailer[2] & 0xef) != 0x00 || trailer[3] != 0x00)
- return NULL;
-
- source_port = trailer[1] & 7;
--
-+#endif
- skb->dev = dsa_master_find_slave(dev, 0, source_port);
- if (!skb->dev)
- return NULL;
diff --git a/target/linux/realtek/patches-5.4/702-net-dsa-increase-dsa-max-ports-for-rtl838x.patch b/target/linux/realtek/patches-5.4/702-net-dsa-increase-dsa-max-ports-for-rtl838x.patch
deleted file mode 100644
index 929f2b9444..0000000000
--- a/target/linux/realtek/patches-5.4/702-net-dsa-increase-dsa-max-ports-for-rtl838x.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/include/linux/platform_data/dsa.h
-+++ b/include/linux/platform_data/dsa.h
-@@ -6,7 +6,7 @@ struct device;
- struct net_device;
-
- #define DSA_MAX_SWITCHES 4
--#define DSA_MAX_PORTS 12
-+#define DSA_MAX_PORTS 54
- #define DSA_RTABLE_NONE -1
-
- struct dsa_chip_data {
diff --git a/target/linux/realtek/patches-5.4/702-net-ethernet-add-support-for-rtl838x-ethernet.patch b/target/linux/realtek/patches-5.4/702-net-ethernet-add-support-for-rtl838x-ethernet.patch
deleted file mode 100644
index 952384ac89..0000000000
--- a/target/linux/realtek/patches-5.4/702-net-ethernet-add-support-for-rtl838x-ethernet.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- a/drivers/net/ethernet/Kconfig
-+++ b/drivers/net/ethernet/Kconfig
-@@ -164,6 +164,13 @@ source "drivers/net/ethernet/rdc/Kconfig
- source "drivers/net/ethernet/realtek/Kconfig"
- source "drivers/net/ethernet/renesas/Kconfig"
- source "drivers/net/ethernet/rocker/Kconfig"
-+
-+config NET_RTL838X
-+ tristate "Realtek rtl838x Ethernet MAC support"
-+ depends on RTL838X
-+ ---help---
-+ Say Y here if you want to use the Realtek rtl838x Gbps Ethernet MAC.
-+
- source "drivers/net/ethernet/samsung/Kconfig"
- source "drivers/net/ethernet/seeq/Kconfig"
- source "drivers/net/ethernet/sfc/Kconfig"
---- a/drivers/net/ethernet/Makefile
-+++ b/drivers/net/ethernet/Makefile
-@@ -76,6 +76,7 @@ obj-$(CONFIG_NET_VENDOR_REALTEK) += real
- obj-$(CONFIG_NET_VENDOR_RENESAS) += renesas/
- obj-$(CONFIG_NET_VENDOR_RDC) += rdc/
- obj-$(CONFIG_NET_VENDOR_ROCKER) += rocker/
-+obj-$(CONFIG_NET_RTL838X) += rtl838x_eth.o
- obj-$(CONFIG_NET_VENDOR_SAMSUNG) += samsung/
- obj-$(CONFIG_NET_VENDOR_SEEQ) += seeq/
- obj-$(CONFIG_NET_VENDOR_SILAN) += silan/
diff --git a/target/linux/realtek/patches-5.4/703-include-linux-add-phy-ops-for-rtl838x.patch b/target/linux/realtek/patches-5.4/703-include-linux-add-phy-ops-for-rtl838x.patch
deleted file mode 100644
index 3682eb30a3..0000000000
--- a/target/linux/realtek/patches-5.4/703-include-linux-add-phy-ops-for-rtl838x.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/include/linux/phy.h
-+++ b/include/linux/phy.h
-@@ -645,6 +645,10 @@ struct phy_driver {
- struct ethtool_tunable *tuna,
- const void *data);
- int (*set_loopback)(struct phy_device *dev, bool enable);
-+ int (*get_port)(struct phy_device *dev);
-+ int (*set_port)(struct phy_device *dev, int port);
-+ int (*get_eee)(struct phy_device *dev, struct ethtool_eee *e);
-+ int (*set_eee)(struct phy_device *dev, struct ethtool_eee *e);
- };
- #define to_phy_driver(d) container_of(to_mdio_common_driver(d), \
- struct phy_driver, mdiodrv)
diff --git a/target/linux/realtek/patches-5.4/704-drivers-net-phy-eee-support-for-rtl838x.patch b/target/linux/realtek/patches-5.4/704-drivers-net-phy-eee-support-for-rtl838x.patch
deleted file mode 100644
index 7743147ea3..0000000000
--- a/target/linux/realtek/patches-5.4/704-drivers-net-phy-eee-support-for-rtl838x.patch
+++ /dev/null
@@ -1,41 +0,0 @@
---- a/drivers/net/phy/phylink.c
-+++ b/drivers/net/phy/phylink.c
-@@ -1242,6 +1242,11 @@ int phylink_ethtool_ksettings_set(struct
-
- /* If we have a PHY, configure the phy */
- if (pl->phydev) {
-+ if (pl->phydev->drv->get_port && pl->phydev->drv->set_port) {
-+ if(pl->phydev->drv->get_port(pl->phydev) != kset->base.port) {
-+ pl->phydev->drv->set_port(pl->phydev, kset->base.port);
-+ }
-+ }
- ret = phy_ethtool_ksettings_set(pl->phydev, &our_kset);
- if (ret)
- return ret;
-@@ -1420,8 +1425,11 @@ int phylink_ethtool_get_eee(struct phyli
-
- ASSERT_RTNL();
-
-- if (pl->phydev)
-+ if (pl->phydev) {
-+ if (pl->phydev->drv->get_eee)
-+ return pl->phydev->drv->get_eee(pl->phydev, eee);
- ret = phy_ethtool_get_eee(pl->phydev, eee);
-+ }
-
- return ret;
- }
-@@ -1438,9 +1446,11 @@ int phylink_ethtool_set_eee(struct phyli
-
- ASSERT_RTNL();
-
-- if (pl->phydev)
-+ if (pl->phydev) {
-+ if (pl->phydev->drv->set_eee)
-+ return pl->phydev->drv->set_eee(pl->phydev, eee);
- ret = phy_ethtool_set_eee(pl->phydev, eee);
--
-+ }
- return ret;
- }
- EXPORT_SYMBOL_GPL(phylink_ethtool_set_eee);
diff --git a/target/linux/realtek/patches-5.4/705-add-rtl-phy.patch b/target/linux/realtek/patches-5.4/705-add-rtl-phy.patch
deleted file mode 100644
index 1ab9e212d4..0000000000
--- a/target/linux/realtek/patches-5.4/705-add-rtl-phy.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- a/drivers/net/phy/Kconfig
-+++ b/drivers/net/phy/Kconfig
-@@ -536,6 +536,12 @@ config REALTEK_PHY
- ---help---
- Supports the Realtek 821x PHY.
-
-+config REALTEK_SOC_PHY
-+ tristate "Realtek SoC PHYs"
-+ depends on RTL838X
-+ ---help---
-+ Supports the PHYs found in combination with Realtek Switch SoCs
-+
- config RENESAS_PHY
- tristate "Driver for Renesas PHYs"
- ---help---
---- a/drivers/net/phy/Makefile
-+++ b/drivers/net/phy/Makefile
-@@ -101,6 +101,7 @@ obj-$(CONFIG_NATIONAL_PHY) += national.o
- obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o
- obj-$(CONFIG_QSEMI_PHY) += qsemi.o
- obj-$(CONFIG_REALTEK_PHY) += realtek.o
-+obj-$(CONFIG_REALTEK_SOC_PHY) += rtl83xx-phy.o
- obj-$(CONFIG_RENESAS_PHY) += uPD60620.o
- obj-$(CONFIG_ROCKCHIP_PHY) += rockchip.o
- obj-$(CONFIG_SMSC_PHY) += smsc.o
diff --git a/target/linux/realtek/patches-5.4/705-include-linux-phy-increase-phy-address-number-for-rtl839x.patch b/target/linux/realtek/patches-5.4/705-include-linux-phy-increase-phy-address-number-for-rtl839x.patch
deleted file mode 100644
index ca6deb74d8..0000000000
--- a/target/linux/realtek/patches-5.4/705-include-linux-phy-increase-phy-address-number-for-rtl839x.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/include/linux/phy.h
-+++ b/include/linux/phy.h
-@@ -188,7 +188,7 @@ static inline const char *phy_modes(phy_
- #define PHY_INIT_TIMEOUT 100000
- #define PHY_FORCE_TIMEOUT 10
-
--#define PHY_MAX_ADDR 32
-+#define PHY_MAX_ADDR 64
-
- /* Used when trying to connect to a specific phy (mii bus id:phy device id) */
- #define PHY_ID_FMT "%s:%02x"